Support » Plugin: Facebook » [Plugin: Facebook] Publish to fan page setting Disabled

  • Updated to version 1.0.2 this morning and the publish to fan page option is now Disabled. I saved the app settings again on my Facebook account and was able to view the available fan pages, select the one I wanted and save the plugin settings.

    The problem comes when I log out of my Facebook account. The plugin settings revert back to Disabled for the publish to fan page option.

    http://wordpress.org/extend/plugins/facebook/

Viewing 15 replies - 91 through 105 (of 159 total)
  • Still the same problem with the new version.

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    @hygglo same problem as the original poster? Can you add details on what you’re seeing, or point me to a comment that explains what you’re seeing? Thanks

    Matt; one page back I give the details. I got the last one but see the post. Not on my wall but YES on my page.
    So short:
    YES = on page
    NOT = Not on page timeline.
    NOT = not on personel wall
    NOT = on personal Timeline

    Error: Failed posting to your Facebook Timeline. Error: {“message”:”Could not retrieve data from URL.”,”type”:”Exception”}

    So it is still the same

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    @black lion That’s a different, unrelated error to the original poster’s issue. Their issue is about access tokens expiring.

    Yours is about a URL issue. Do you mind opening up a separate thread so that we can track them? Thanks

    Matt with all respect, If you look to the post above yours you can see:
    YES = on page
    NOT = Not on page timeline.
    NOT = not on personel wall
    NOT = on personal Timeline

    If this is ONLY for a Page let me know.

    The error i sending to is the erro where i was talking already in a other post. A lot of peple talking ans asking about it. No answers over there. So I try out the latest to see if this will complete the error. But I deactived it quick because the error whas there still and then only to a page not to the page tinmeline and not to my fanpage and timline.

    I’ve had the issue as well, however since the latest version it seems consistant that social publishing to my fan page works for any auhtor on my blog, as long as I’m logged in to my regular fb account, and not my fan page.

    No problem, I can stay logged in, however, the access token expires after about 2 hrs. So other authors on my blog only have a two hour window if they want their posts to go to the fan page.

    And, they can’t simply go to the settings themselves and re enable social publishing after it expires, because it’s not there!

    It appears social publishing is only available to the person logged in to the fb account associated with the fan page for which social publishing is enabled.

    But all authors still have access to the setting which enables posting to the authors timeline. it doesn’t appear to expire.

    What a confusing mess, ..I’m just wondering how it’s supposed to work,
    how much of this behaviour is a bug?

    @matt Kelly

    It sets the “Publish to fan page” to “Disabled” I haven’t investigated it closer but it seems to be connected to when someone else than me updates with a post.

    The post is transfered to the fan page but thereafter it’s set to disabled.

    Okay, after more testing under different users it now appears that although the user logged in to the associated fb account is the only one who can re activate the social publishing setting after it expires, authors may access the “Mention Pages” widget from the post editor, and from there may seach for and log into the fb account associated with the fan page that is set in social publishing… which then reactivates social publishing in the plugin settings. … or so it would appear. I need another author to confirm.

    And oddly, my access token has been active for about 8 hours now, yesterday it would expire after about 2 hours, even if I was still logged in to fb and my site.

    the token expired, probably in the last hour. The only thing I changed was to close my fb browser (but I did not log out). But the token remained active for at least 10 min or so after that because I checked it a few times. Not sure if closing the browser had anything to do with it.

    But what’s different now is, my author can reactivate social publishing through the fb plugin settings page! Before the option was only available to me.

    So now I wonder, is it the case that once an author searches for and logs into the fb account throgh the “Mention Pages” widget, then the social publishing setting for the plugin becomes availble? maybe for just that author? still more testing ahead.

    Plugin Contributor Matthew Hui

    (@zazinteractive)

    I’ll try to get a fix for the multiple authors bug

    I have the same problem. My scheduled posts aren’t appearing on my Facebook page, because “Publish to fan page” keeps changing to Disabled.

    since I got 1.0.3 I don’t have that issue anymre, it’s stayed active over 2 days. I haven’t had much chance to test how other authors experience the plugin, there’s messages in the post editor asking authors to log into their fb account. I need to make another fb account to test as an author and see what happens.

    I am lucky guy.. I have installed 6 days back and it works perfect. I am using it in a Multi site environment with more than 100 posts per day. I do have little probs in excerpts , but the actual problem of getting disabled is no more.
    Finally i am a happy user now !!! Thank you guys for all your hard work.

    Why @matt; is not telling people with all the problems that this update is out. Now i have every day to check ( wast of time)
    Where to get this latest???
    Is it realy working GOOD??

    I need it like @haneeputtur and also more than 100 postings a day. (Newspaper)

    Yeah, I stumbled on the latest version, it’s not in the wp repository for some reason (last I checked anyway)

    http://blog.haneefputtur.com/2012/08/facebook-plugin-for-wordpress-103.html

Viewing 15 replies - 91 through 105 (of 159 total)
  • The topic ‘[Plugin: Facebook] Publish to fan page setting Disabled’ is closed to new replies.