Support » Plugin: Facebook » [Plugin: Facebook] Publish to fan page setting Disabled

  • Updated to version 1.0.2 this morning and the publish to fan page option is now Disabled. I saved the app settings again on my Facebook account and was able to view the available fan pages, select the one I wanted and save the plugin settings.

    The problem comes when I log out of my Facebook account. The plugin settings revert back to Disabled for the publish to fan page option.

Viewing 15 replies - 16 through 30 (of 159 total)
  • Not that you guys/gals need another +1… but +1 here as well. Thanks!



    I’m having a similar problem. My “Publish to Fan Page” option has never worked until JUST NOW when I tried to make a test post so that I could copy and paste the error message I’m receiving. Usually it says it can’t post to my fan page because the option has been disabled and it asks me to re-enable it.

    Also, the plugin posts to my personal timeline (or posts on the ‘author’ timeline) but I do not have that option selected and don’t want it to post on my personal timeline. I have no idea why it’s doing that.

    I’m having the same issue, here’s the error messages I get:

    Failed posting to Physics CrossFit’s Timeline because the access token expired. To reactivate publishing, visit the Facebook settings page and re-enable the “Publish to fan page” setting. Full error: {“message”:”Error validating access token: The session is invalid because the user logged out.”,”type”:”OAuthException”

    {“appid”:”402202813150236″,”version”:”1.0.2″,”domain”:””,”social_publisher”:{“enabled”:”true”,”publish_to_fan_page”:[],”mentions_position”:”both”},”recommendations_bar”:{“trigger”:”50″,”read_time”:”20″,”action”:”like”,”side”:”right”,”show_on”:”all posts and pages”},”subscribe”:{“layout”:”standard”,”width”:”250″,”colorscheme”:”light”,”font”:”arial”,”position”:”both”,”show_on”:”all posts and pages”},”comments”:{“num_posts”:”20″,”width”:”470″,”colorscheme”:”light”,”show_on”:”all posts and pages”},”send”:{“colorscheme”:”light”,”font”:”arial”,”position”:”both”,”show_on”:”all posts and pages”},”wp_ver”:”3.4″}

    same problem

    I also have this problem.

    If I enable the “post to fan page” and make a test just after that, it’s OK…

    But if a few meinutes later another author post a message on the blog, the options get diabled… and without any error message 🙁

    I am just wondering will there be any use of waiting for the response from the developer or better to go ahead with other plugins?
    Till now no one from dev team confirmed about this issue.

    It seems that I need to be connected to facebook with my browser to be able to post to my fan page.

    If someone else posts an article, the “post to fan page” gets disabled.

    This is a major BUG for this plugin, I’ll ave to revert to Wordbooker or something else.. 🙁

    Yes, you must be logged into your Facebook account through your browser in order to post. Just like using the Graph API, you need to get an access token for Facebook to allow you to push content to their servers, and that token gets generated by logging in.

    I agree it is a pain when you’re trying to deliver this plugin to customers, where you can’t do any setup for them without almost connecting to Facebook as them.



    I remain logged into Facebook and I’m still having issues. I wish I knew what’s wrong. This plugin is GREAT in theory.

    Same problem with the publish to page being disabled.

    Plugin Contributor Rishi Gharpuray


    This issue has been resolved since the release of 1.0.2. It is now available on github ( If you pull the newest version, and the issue still persists, don’t hesitate to let us know!

    I count at least three posters in this thread who are experiencing the “Disabled Problem” with Version 1.0.2 of the plugin. And I can add myself to that list.

    Yeah Rishi, this problem is definitely stemming from the 1.0.2 version from the sounds of it. Or at least many of the users on here are using that version and complaining of the problem. This version did not fix the issue, in fact from what I can tell it was the version that introduced this issue.

    When we can expect a bug fix for that issue?

    I’ve got the same problems.
    Does anyone has a idea how to solve this issue?

Viewing 15 replies - 16 through 30 (of 159 total)
  • The topic ‘[Plugin: Facebook] Publish to fan page setting Disabled’ is closed to new replies.