Support » Plugin: Facebook » [Plugin: Facebook] Publish to fan page setting Disabled

  • Updated to version 1.0.2 this morning and the publish to fan page option is now Disabled. I saved the app settings again on my Facebook account and was able to view the available fan pages, select the one I wanted and save the plugin settings.

    The problem comes when I log out of my Facebook account. The plugin settings revert back to Disabled for the publish to fan page option.

    http://wordpress.org/extend/plugins/facebook/

Viewing 9 replies - 151 through 159 (of 159 total)
  • edwinj have you tried leaving it 24 hours and rebooting?!!!? This worked for me. So far so good… worked for 5 posts. How do you get rid of the html at the beginning? Someone posted a link on how to do this but I cannot find it.

    I also have this problem. It works for exactly one post, then changes back to [Disabled]. I’d love a fix so I can dump RSS Graffiti!

    Been trying to get this working for ages now.

    Completely removed version 1.0.2 and installed and setup 1.0.3.

    Works great posting to my Facebook page wall when I am logged into Facebook. As soon as I log out of Facebook, none of my scheduled wordpress posts are being posted to the Facebook page wall.

    When I then view the Facebook plugon settings “Link your Facebook account to your WordPress account to enable.” appears next to “Publish to fan page”. If I then refresh the Facebook settings page, “Publish to fan page” then becomes “Disabled”.

    It looks like this plugin needs to store my Facebook account details as well as the app and page details, but isn’t doing so.

    This clearly looks like it isn’t going to work.

    Can anyone suggest an alternative plugin that will post scheduled posts to my Facebook page wall while I am logged out of Facebook?

    Many thnaks

    i

    I was going to post and say 1.03 is working for me – so solved, infoforme I’ve just had a look at the settings I’m using.

    Only using “social publisher”

    Publish to author’s Timeline [?] Yes ticked
    Publish to fan page [?] Yes “No oil in the lamp”
    Mentions show on homepage [?] No clear not ticked
    Mentions position [?] Both
    Publish for [?] postpage Post ticked only

    Hope this helps I don’t need to logged into FB fro this to work. Sometimes we get html at the beginning of the post on FB sometimes not.

    tjalexander70

    (@tjalexander70)

    Still not working for me. “Publish to fan page” still keeps reverting to Disabled.

    pamelaz22us

    (@pamelaz22us)

    Also had this happen this morning.

    SloKenny

    (@slokenny)

    I did install V 1.0.3 and got it to work. The Fan page is holding, not going back to “Disabled”.

    One thing I see is some new settings underneath the “Social Publisher” section. They are Publish for [?] post [ ] page [ ] ne_custom_slides [ ] ne_featured_posts [ ]

    You need to at least tick off the Post box for the plug-in to post onto the FB page.

    tgrblogger

    (@tgrblogger)

    Not sure what’s happening with version 1.0.2, but Publish to Fan Page is still being disabled when I first log into my WordPress blog. This seems to be an OAth connection issue, as once I check the box, it stays selected until I log out of my blog admin and posts publish to the fan page. If I forget to check the setting after logging in and put up a post, the post doesn’t publish to the Fan Page, and when I look at the settings afterwards, I can see that the Publish to Fan Page is deselected. Unfortunately, selecting it then doesn’t allow for me to report to the account and Fan Page.

    I have multiple fan pages associated my Facebook account, not sure if that’s why it behaves this way. I do use the plugin on at least two other blogs, all experiencing the same behavior. It doesn’t matter whether I’m logged into Facebook or not.

    I’m also experiencing where the first 50 characters are text with HTML markup showing. Then it repeats the same line below without the HTML markup.

    One final thing… I notice a broken image just below the Save Changes button. It goes to http://www.facebook.com/impression.php?plugin=wordpress&payload= along with a long list of attributes, including the name of the fan page selected. Can anyone tell me what this is used for?

    EDIT: Changed this comment to version 1.0.2, I’ve not tried 1.0.3 and won’t until I see consensus that these issues are resolved.

    Sapphire

    (@sapphire)

    Same problem. I first downloaded this just a week ago, and it never once auto-posted anything. Every single time, it says it’s been disabled and I have to manually post it anyway, so what’s the point of the plugin?

Viewing 9 replies - 151 through 159 (of 159 total)
  • The topic ‘[Plugin: Facebook] Publish to fan page setting Disabled’ is closed to new replies.