WordPress.org

Support

Support » Plugins and Hacks » Facebook » [Resolved] [Plugin: Facebook] Publish as Author Doesn't Stay Selected

[Resolved] [Plugin: Facebook] Publish as Author Doesn't Stay Selected

  • I’m trying to set-up the plugin and having an issue with the Author Publishing part, I have connected and the plugin posts fine to our fanpage, but it won’t publish to our personal timelines. I have set-up the opengraph as per the instructions. What I noticed is in the setting I’ll have Author Publish checked I’ll save setting do my test post then go back to the settings and the Author Publish is unchecked. Is this a bug??

    http://wordpress.org/extend/plugins/facebook/

Viewing 15 replies - 16 through 30 (of 53 total)
  • Try disabling all the plugins if you are still having issues to see if that fixes the problem. If it does, then one by one activate the plugins to figure out which plugin was causing the conflict.

    The option to ‘publish to authors timeline’ if it unchecks after you have authorized the Facebook app, its no big deal, as all that does it create a pop up window to the Facebook Developers page that shows you what to do. As long as you have followed all the instructions, it should work.

    Cloudflare has nothing to do with your website blog not working with the Facebook Plugin.

    @bluechip

    I disabled every single plugin except the facebook one, and it is still happening.

    pcland

    @prettycoolland

    I tried using another plugin and it worked. I think it’s because it prompted me to grant it permission to post to my timeline (just like the permission screen that pops up when you use any other app on Facebook) while the Facebook plugin didn’t.

    @prettycoolland

    What plugin?

    Here’s my rundown:

    Normal blog writer can post to a Fan Page with comment form appearing on the post edit page.

    Only ONE fan page can be selected for all authors on the blog, since normal user never sees the Facebook settings screen, only admins do.

    I am only going to assume, that each blog author can authenticate to his own FB timeline/page. So the writer can post to HIS/HER time line AND the designated FB Fan Page for the blog.

    Admin user can post on Fan Page, but the comment form does not appear, but the post will go to the fan page, sans any comment.

    Neither normal user or admin user will get posted to any timeline, even though you are authenticated and you do see the comments entry form on the blog post screen.

    It appears there is not much we can do but wait until WP/FB authors look into this for us.

    And if a Blog Author leaves the FB comment entry box empty on the New post screen, the posting still goes to the Fan Page.

    Plugin Author Facebook

    @facebook

    Hey folks, this gets disabled if there’s a Facebook API error.

    We’re working on a couple of things to make this flow easier.

    Please keep your eyes peeled for an update to the plugin next week and follow up with the results you get.

    Thanks

    We’re assuming the error is “Can’t Post to the Timeline!” Can you acknowledge that there is something flaky here, so we can all quit pulling our hair out and just wait for you all to update it.

    It’s a great start, real close!

    It is great to know that the reason is because of a FB API error. No more time to waste trying to figure out why it was happening.

    I think it is a great plugin and I look forward to next week’s update.

    Ran in exact same issues after double-checking all the set-up a dozen times (+ disabling all other plugins etc)…

    I spent half my morning debugging this PoS of a plugin and here are the results (ongoing work):

    • Checkbox gets unticked because the morons who programmed this plugin decided it was the appropriate response, when the posting fails due to an API error. Instead of, you know, displaying a freaking error message.

    • Posting fails because the plugin uses what appears to be outdated API specs. Gory details for debug-minded people:
    – WP’s implementation of makeRequest throws a mysterious ‘400 HTTP’ error.
    – when running the same query manually, Facebook API returns code ‘2500’: Unknown path components: \/my-app-id:publish
    – manually changing the API parameter to replace /<em>my-app-id</em>:publish by news.publishes successfully posts.
    – haven’t yet figured an easy way to change that in the plugin itself…

    Either way, it looks like FB devs cannot seem to keep up with their own API.

    Update: THE FIX

    Following bit of code-tinkering did the trick for me (until FB breaks their API compatibility again, I guess). Use at your own risk.

    – Edit file fb-social-publisher.php
    – Around line 344, replace:

    $publish_result = $facebook->api('/me/' . $options["app_namespace"] . ':publish', 'POST', array('message' => $author_message, 'article' => get_permalink($post_id)));

    By:

    $publish_result = $facebook->api('/me/' . 'news.publishes', 'POST', array('message' => $author_message, 'article' => get_permalink($post_id)));

    – Of course, you still need to have added the action to Open Graph in your FB app settings (follow the plugin instructions, except you need to create a ‘Publish + article’ action).

    I suspect a similar fix can be done for the post-to-page function, but do not use it and do not really have the time to debug this too.

    Incidentally: the publishing function of this plugin is quite poor: doesn’t bother posting a summary or suggesting a thumbnail… I threw away my own custom FB-posting plugin, thinking the official one would be better-supported and more advanced: bitter disappointment there.

    Hi fellas

    Iam also face this problem.
    Is there any simpler method to enable post to timeline feature?

    Plugin Contributor Matt Kelly (Facebook)

    @mattwkelly

    As we said above, we’re pushing a fix this week (tomorrow, actually). Thanks.

    Plugin Contributor Matt Kelly (Facebook)

    @mattwkelly

    Dave: “I threw away my own custom FB-posting plugin, thinking the official one would be better-supported and more advanced: bitter disappointment there.”

    We launched next week. We’re working on a bundle of fixes. Thanks for the feedback, but please keep it constructive.

    Plugin Contributor Matt Kelly (Facebook)

    @mattwkelly

    Can you try 1.0.1 (http://wordpress.org/extend/plugins/facebook/changelog/) and let me know if you’re still seeing issues? Thanks

    Hey Matt,
    Well it’s at least staying selected now but returning the following error

    “Failed posting to your Facebook Timeline. Error: {“message”:”Unknown path components: /vgrevolution:publish”,”type”:”OAuthException”}”

    I tried removing the Open Graph object and putting it in fresh and still had the issue. When I get a moment I’m going to try to remove all authorization and start fresh reauthorizing everything.

    Posting to Fan Page works fine, just not author timeline.

Viewing 15 replies - 16 through 30 (of 53 total)
  • The topic ‘[Resolved] [Plugin: Facebook] Publish as Author Doesn't Stay Selected’ is closed to new replies.
Skip to toolbar