WordPress.org

Support

Support » Plugins and Hacks » Facebook » [Resolved] [Plugin: Facebook] Publish as Author Doesn't Stay Selected

[Resolved] [Plugin: Facebook] Publish as Author Doesn't Stay Selected

  • I’m trying to set-up the plugin and having an issue with the Author Publishing part, I have connected and the plugin posts fine to our fanpage, but it won’t publish to our personal timelines. I have set-up the opengraph as per the instructions. What I noticed is in the setting I’ll have Author Publish checked I’ll save setting do my test post then go back to the settings and the Author Publish is unchecked. Is this a bug??

    http://wordpress.org/extend/plugins/facebook/

Viewing 15 replies - 1 through 15 (of 53 total)
  • I am also getting this problem.

    I’ve tried several times, and the ‘Publish to author’s Timeline’ option will remain checked, until I publish a test post. As in jlomaga’s post above, the activity is being shared on my Facebook Page, but not on my personal timeline.

    I’m having the same issue. Everything works fine, except publishing to my personal timeline.

    After making my own post about this same issue, I run across this thread.

    Anyone know a fix?

    Am having the exact same problem.

    Ticked the box, and saved.

    I followed these steps – https://developers.facebook.com/wordpress/#author-og-setup

    The post came up in the timeline for the page I created (yay I thought) But it didn’t show on my personal/author timeline.

    Then I tried to complete the final step of submitting the Open Graph action/object. But facebook tells me that I haven’t successfully made the first post yet (partially true I guess).

    To fix this issue you need to go to your Facebook Applications settings located here: https://www.facebook.com/settings?tab=applications. Then the delete the app that you created for your blog from the list. Don’t worry you will re-add again in a few seconds. Then go to your blogs admin area and go to the ‘Facebook’ plugin settings and check on the ‘Publish to author’s Timeline’ and go to the bottom and click on SAVE. You should see a re-auth box or a link below where you checked off ‘Publish to author’s Timeline’. It worked for me.

    I removed the app from my FB account.

    Then went through, checked the box to post to author timeline. Followed the instructions again to create a new action type (after clearing out the old one).

    Went back to wordpress, where indeed, as you say @bluechip the link appears – though that link seems to apply to posting onto Pages. I went through and re-added the app to my fb account. Gave permissions for everything, etc.

    So, back on the FB Plugin settings I get the drop down of my pages visible. I leave it set to disabled. The checkbox for author timeline is checked. For good measure, I hit save again.

    Then new post. I give title, body, Facebook Author post option, then publish. The post appears on my site, but then nothing shows on either fb page, or my personal timeline. Only expected it to show on my personal timeline.

    Back to the Facebook Plugin settings and mysteriously the option to post to author timeline is no longer checked!

    So I recheck the author timeline button, and add the Page timeline post option again. Save.

    Another new post….

    Author Timeline shows nothing.
    Page Timeline shows the post perfectly.

    Because the Author timeline post has failed, I cannot complete the Open Graph setup.

    I’m also having the same issue.

    Me too!

    Me three… frustrating!!!

    I posted the solution here, Facebook WordPress Plugin: Publish as Author Solution.

    Let me know if you have any issues.

    Still no luck.

    I tried removing the plugin and reinstalling. I have tried deleting the app and creating a new app and I have removed it from my Authorised Apps.

    It re-authorises, but doesn’t post to my timeline, so I can’t submit the open graph request.

    Not too sure what else to try.

    Same as @mtedwards – still no luck.

    Anyone else using CloudFlare? Just wondering if that’s messing with stuff?

    I’m not using cloudflare, and it’s still messed up…

    bluechip’s suggestion didn’t work either.

    Having the same problem, tried bluechip’s solution and still the post does not appear on timeline. As said, the option remains checked until a new post is made, after which it is unchecked.

    I’ve deleted the Facebook plugin and reinstalled also.

    pcland

    @prettycoolland

    Having this problem as well. The option to ‘publish to author’s timeline’ keeps unchecking after the post is published. Think I’m going to try another plugin..

Viewing 15 replies - 1 through 15 (of 53 total)
  • The topic ‘[Resolved] [Plugin: Facebook] Publish as Author Doesn't Stay Selected’ is closed to new replies.
Skip to toolbar