Support » Plugin: Facebook » [Plugin: Facebook] Posts without og:description content

Viewing 10 replies - 1 through 10 (of 10 total)
  • I am having exactly the same issue, no content posted from WordPress. Also random images off the site posted with the FB posting.

    Me too, I google it but could not find anything to solve. Does anybody have a solution for this

    I too face the same issue. I can just see the title and no description.

    Hi all … anybody got any suggestions what I and maybe others are not doing correctly to cause this? Anybody?

    Thanks in advance!

    Yes now it started posting after I upgrade their new version 1.0.2. However it started giving new issue. Its showing wrong thumbnails for the posts.

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    @derfeluk, @ssamioglu, @edwardnh, can you upgrade to 1.0.2 and let us know if that resolves the issue? Thanks

    @haneefputtur, please open a new thread with info. Thanks!

    Matt, the issue seems to have been largely resolved.

    However, my og:description explicitly tries to use an excerpt that I set up for each post. The Facebook plugin bypasses this and uses the first characters of the post instead. I don’t think there’s anything wrong with that implementation but if I check the metadata or run the Facebook debugger (http://developers.facebook.com/tools/debug), I see the correct data for the og:description.

    What I would like to see is the correct og:description data in the excerpt below the title on the Facebook page instead of the beginning characters.

    Also, there are a number of members-only pages on the site I post to. is there a way to feed Facebook the right og information despite the membership-only state of those pages?

    Many thanks for your help here.

    @matt
    Thanks Matt, but I am already using 1.0.2!
    I have been using Facebook Page Publish and initially that was taking the first image in each post but now no images are displayed in FB. No changes have been made at the plugin side to cause this change in behaviour.

    Further, neither have I switched off all other plugins to see if it works on its own. This is something I will test in three weeks after we return from Summer trip!

    Thanks

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    @edwardnh How are you generating that excerpt? Via WP’s stock except feature, or another plugin?

    “Also, there are a number of members-only pages on the site I post to. is there a way to feed Facebook the right og information despite the membership-only state of those pages?”

    Unfortunately, no. Your page must be public in order for Facebook.com to read the content.

    @derfeluk Can you post steps that you’re taking so that we can try to reproduce? We’re not seeing this issue by the normal steps that we take. Thanks

    @matt …. I have just switched off Facebook Page Publish and switched on Facebook. Did a test post, perfect in every way, used the first image and displayed content and Facebook Status as expected.

    I cannot explain the sudden and spontaneous correct working, but work it did on that occasion.

    Will try again …

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Facebook] Posts without og:description content’ is closed to new replies.