Support » Plugins and Hacks » [Plugin: Facebook] Post to author timeline authentication

[Plugin: Facebook] Post to author timeline authentication

  • i am facing an authentication problem. I followed instructions to allow posting from wordpress to author timeline on facebook. I created the open graph action, then created a post on wordpress and went back to click submit on open graph action. I could not do it because I am not authenticated and therefore facebook is not recognizing the post as coming from me. so how do i authenticate myself


Viewing 15 replies - 1 through 15 (of 72 total)
  • mattkelly


    In your WordPress admin dashboard, you should see a yellow admin notice prompting you to authenticate with Facebook. Click the link.

    Do you see that?

    no, that is where my problem is. i refreshed my wp dashboard several times, then repeated the process alltogether, and i still cant see anything prompting me to authenticate with facebook

    I created a NON-admin user on one of my blogs, and switched to that user and in fact I was then able to authenticate. And the app showed up in my Facebook app list.

    And when I created a new post, the FB box was there, I entered some text, published the post and


    I switched to another blog. Added the same non-admin user to the blog (all within multi-site) and it did not ask to authenticate with the new app on the blog. I’ve created 3 different apps on FB for the three different blogs, two have authenticated, NONE will post yet.

    Will I have to be NON-ADMIN to ever get this to post?
    Can’t admins post to their FB timeline?

    Sometimes it’s easier to been logged in as admin when doing blog work on a single author blog.

    What else should I try?

    Someone else on another thread is saying that the problem occurs when you already have facebook plugins in your blog. he says, you can only run one facebook plugin at a time. so you have to uninstall any related plugins from third parties to get authenticated by Facebook official plugin. I have not tried it yet. in fact, i am not sure i want to replace working plugins with questionable one.

    I did deactivate my other social apps using FB. But then I get the api error after clicking the link.

    I click on the “Publish to author’s Timeline” option and a pop-up window telling me how to create the action/type pops up. I follow all the instructions, making sure to save the Facebook page with all the check marks, creating a new post on my blog (which shows up in my facebook timeline immediately).

    However, when I click on the “submit” button in Facebook as indicated, I get the error message stating I have to “publish at least one action to your Timeline using this action type”. When I go back and visit WordPress Facebook plugin page, the check mark on the “Publish to author’s Timeline” is gone, even though I saved the page.

    And I never see any notification in WordPress of any kind asking me to authenticate. HELP? 🙂

    sugarpopboutique – I have the EXACT same problem as you! I’ll have to keep checking to see what the issue is.

    I normally search the web until I resolve the issue myself, but this one is a bit tricky lol… especially since they just released this Facebook for WordPress did they not? Ehhh… I’m still trying! Will update if I find anything helpful.

    This. Is. So. Frustrating.

    Has anyone figured out the problem?

    I can log in as two different WordPress users (each having their own Facebook accounts). Both are admins of the Facebook Page I set up to use for my website, and when posting to WP from either account, the post shows up on the FB Page (and if I mention any other page, it posts there too – as the User, not the Page).

    It seems to work for pages easily, but the users cannot post it to their own Facebook accounts! Followed the instructions to the T and I get the same

    publish at least one action to your Timeline using this action type


    I guess I want to have each user that makes a post to be able to have their posts on their own timelines, and I want every post to show up on the FB Page.

    Or is it not supposed to function like this?

    I had a few simple issue that happen, but what i have seen it was Facebook fault due to them upgrading there site and slow response from my fan page loading half the time. I just redid the plugin reinstall and waited till facebook got there stuff together. Only issue i have is that this plugin post comments on my pages.. grrr…

    anyone found solution for this problem

    I got the same problem, I can’t find the authentication message on WP dashboard.

    I was having the same problem. I got past the “publish at least one action to your Timeline” error by going to the command line in Linux and copying and pasting the publish code that shows up under “Get Code” for Action Types — I made sure to substitute my app ID for /me in the URL. I did get a response back, and Facebook no longer gave me the “publish at least one action to your Timeline” error.

    However, posts still do not go to my Facebook wall (not even the one that I manually posted using curl). I have never been asked to authenticate with Facebook from my WordPress blog, as the documentation indicates I would be.

    Possible complicating factor: I had Wordbooker installed but deactivated. Thinking it might still be interfering, I deleted it, then deactivated and deleted the Facebook plugin, and reinstalled it. I’m still having the same trouble though — posts are not going to my wall even though I checked the option for them to do so and saved the options. I refresh that page and the option is still checked. When I make a new test post, it does not go to my Timeline, and that option is unchecked. When I check it again, it pops up https://developers.facebook.com/wordpress/#author-og-setup.

    Maybe I need to wait for the Publish action to be approved and no longer “pending”? I got the impression from the documentation that the post would go to your wall regardless of the approval status though.

    Hmm, as a follow-up, I went to my Timeline and then clicked Activity Log. The top item on that was my post to my blog, set to Allowed on Timeline. The time on it corresponds to the post that I made manually via curl on the command line. However, it is still not actually visible on my timeline.

    I also tried creating another admin user. When I logged in as that user, it did ask me to authenticate with Facebook. I did so, and created a new post as that user, and it did not show up in my timeline or my Activity Log.

    As further information, I host my blog through BlueHost, in case there are any known issues with that host.

    Well, sorry for spam posting, but it seems that manually-entered curl post did come through to my “Activity” section (I was expecting it to come in as a status update, I guess).

    This makes me think that:

    1. The manual curl method worked as it was supposed to, but it just put the post somewhere I wasn’t expecting, and…

    2. There is something wrong with calling curl through PHP. I have successfully used curl on my host before, so maybe it’s just that Facebook is blocking it for some reason? In any case, the plugin code should be able to detect curl errors and report on them if anything goes wrong.

Viewing 15 replies - 1 through 15 (of 72 total)
  • The topic ‘[Plugin: Facebook] Post to author timeline authentication’ is closed to new replies.