WordPress.org

Support

Support » Plugins and Hacks » Facebook » [Resolved] [Plugin: Facebook] Plugin not working with WP 3.1.X

[Resolved] [Plugin: Facebook] Plugin not working with WP 3.1.X

  • Like I have written in my (German) blog there are two function calls that are not (correct) working with WordPress versions less than 3.2!

    1) The function fb_js_sdk_setup() in file fb-core.php uses the wp_enqueue_script() function that has to be called using the Action-Hooks ‘wp_enqueue_scripts‘ and / or ‘admin_enqueue_scripts‘! Otherwise the Facebook Connect Javascript file is not loaded…

    2) Additionally, the Action-Hook ‘wp_footer‘ is not called in the backend! Therefore you must add a ‘admin_footer‘-Hook, too…

    But even after writing these both hacks it does not run 🙁 because of an JavaScript Error that appears just for seconds after clicking the “Link your Facebook account to your WordPress account”-link. It says that one frame is not allowed to modify another one that has not the same URL…

    Any ideas, tips, or hints?

    http://wordpress.org/extend/plugins/facebook/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Matt Kelly (Facebook)

    @mattwkelly

    Yes, we launched with an incorrect minimum version number. We’ll be updating to 3.2.1.

    Thanks for the report.

    Matt, I originally had 3.2.1 running when I installed the Facebook plugin. There was an error in the javascript that prevented me from authenticating my facebook user (error was about the FB object not being loaded, threw the error when i clicked on the ‘link your facebook account…’ link.

    Updating to 3.4 fixed this issue. Given that there’s no other feedback (as far I can see) from the community on if the plugin works with 3.2.1, i’m giving you a heads up that maybe 3.2.1 shouldn’t be the minimum version.

    Cheers.

    Plugin Contributor Matt Kelly (Facebook)

    @mattwkelly

    patv: I’m running 3.2.1 on my personal site and everything is working well. Thanks for the feedback, though.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: Facebook] Plugin not working with WP 3.1.X’ is closed to new replies.
Skip to toolbar