Support » Plugins and Hacks » [Plugin: Facebook Page Publish] Thumbnail not working properly

[Plugin: Facebook Page Publish] Thumbnail not working properly

  • Hi there,

    Thx for the plugin. When a post is published to Facebook it includes the link to a picture in the single post. So when I put a a picture at the very top of the post it is included in the facebook post. This is not right as I have set the plugin to post thumbnails (featured image) and to show excerpts but something is wrong as it is picking up the image from the actual single post if it was pulling the excerpt this image wouldn’t appear.

    Any ideas?

    Here is an example I have bolded the link that is incorrect:

    Sporting Post
    http://www.sportingpost.co.za/wp-content/uploads/splash-gold-gr2post-merchants-d110617.jpg Splash Gold
    Showing a nice turn of foot from off the pace, Splash Gold ran out a fluent winner of the Post Merchants (handicap) over 1200m at Greyville on Friday evening. This was the three-year-old’s first Black Type success and it…

    Post Merchants Hcp: Making A Splash
    Frontpage, Racing & Sport, Reviews


Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author mtschirs


    Hi stemie,

    Sorry for the late answer. If you are still interested in a solution, could you please post a link to a wordpress post wich is not posted correctly on facebook ?

    Thank you,

    hey, I’m having this same problem. about 80% of mine are posing without a thumbnail and it previously worked perfect…


    If you moved to cloudflare and no thumbnail is displaying at all, then cloudflare is the problem. I disabled cloudflare and everything worked fine again — they are aware of the problem and are working on it with FB.

    I’m still having this issue. I tried posting the same post about 10 times, each time reuploading an image and it wouldn’t post the image to my facebook. when I posted something to my wordpress through a feed, it posted the photo to my FB just fine.

    here’s one that didn’t work:

    I love the long tail boats and their colors are a great contrast to the amazingly blue waters of thailand. This is a 3 exposure HDR image processed using photomatix and photoshop.

    Posted by Tracy Lee on Wednesday, April 4, 2012

    There’s no consistency to when it will post a thumb and when it won’t. But today trying to post through the web to my wordpress- it wouldn’t update a thumb on my FB.

    -so frustrated, please help!

    Run this link through the Facebook Linter/Debugger and repost your article/link. See what happens.


    I think this plugin needs something where it can submit to the debugger first before posting to FB. Without an FB app to link to FB, it’s basically hit and miss.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Facebook Page Publish] Thumbnail not working properly’ is closed to new replies.