Support » Plugin: Facebook Page Publish » [Plugin: Facebook Page Publish] Can't Connect to Facebook

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author mtschirs

    (@mtschirs)

    Hi dmeglio,

    thank you for reporting this problem. I think your webserver does not allow outgoing http/https-connections. I will integrate a more detailled diagnostic message into the plugin soon.

    Please do the following:

    1. Create a new .php file and copy the following code into it:

    <?php
    
    header("Content-Type: text/plain");
    
    require_once( dirname(__FILE__) . '/wp-load.php' );
    
    $request = new WP_Http;
    $api_url = 'https://graph.facebook.com/19292868552';
    $response = $request->get($api_url);
    
    print_r($response);
    ?>

    2. Store the php-file in the root directory of your wordpress and use your webbrowser to execute it.

    3. Post the result here.

    WP_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => SSL certificate problem, verify that the CA cert is OK. Details:
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    )

    )

    [error_data] => Array
    (
    )

    )

    Certainly looks like an error. Not sure what to do about that though…

    I added array(‘sslverify’ => false) to each of your $request->get calls and it worked. Any chance you could do that in the code?

    Well I fixed it on my local server. Now I deployed to our production server. I clicked the “Authorize” button and I get:

    At the top:
    Authorization rejected:

    At the bottom:
    Facebook recognized these settings as invalid!

    Note that the first message does not show a reason. Any thoughts?

    Plugin Author mtschirs

    (@mtschirs)

    Hi dmeglio,

    thank you for posting the test results.

    I have uploaded a new version of the plugin that allows to disable SSL verification. I hope this resolves your problem (since it is a problem with your server, I can not verify the patch myself).

    Please do the following:
    1. Reinstall the plugin (I did not change the version number).
    2. Open the plugin menu, select “Editor” and open “facebook-page-publish/fpp_index.php”.
    3. Search for define("SSL_VERIFY", true);, replace it with define("SSL_VERIFY", false); and save your changes.

    The only drawback of this solution: The facebook-SSL-certificate is no longer validated. A better solution would be to ask your web hosting company to update their SSL certificates.

    Well now I can connect, so I am closer. However, I’m getting the second error I described. After I click the plugin activation I just get “Authorization rejected: ” with no reason given. And at the bottom it says “Facebook recognized these settings as invalid!”

    And while I agree with you that SSL verification would be nice, my current host is godaddy. The odds of getting them to setup the certificates is somewhere around 0%.

    Plugin Author mtschirs

    (@mtschirs)

    Didn’t read your second post, looks like you already figured it out yourself 😉

    Concerning the “Facebook recognized these settings as invalid!”-message:
    In your facebook-application settings, you have to fill in your blog’s URL into the URL field. Otherwise, your blog will not be authorized to post to facebook. See the updated “Detailed setup instructions” on the plugin’s settings page.

    Does this resolve your problem?

    (I will adress the problem concerning the missing reason with the next update)

    Sorry, we both seem to be responding before getting to the last message!

    I have the URL of my main website, http://mysite.com should to be the actual URL of my blog? http://mysite.com/blog?

    Plugin Author mtschirs

    (@mtschirs)

    Perhaps, but I can’t verify that now (time is running out). I will experiment with the facebook settings and release an updated version later or tomorrow. If you come across a solution before I do, it would be nice to post it here.
    Thank you for your feedack and patience!

    I did a lot of testing, I cannot seem to figure it out. I don’t know if it is Facebook’s fault or the plugin, but I always get that message and it won’t connect. I authorize the plugin, but no luck. The URL is set correctly. I’d be happy to provide any information you need to diagnose this.

    Have you discovered anything with this problem?

    Plugin Author mtschirs

    (@mtschirs)

    I was not able to reproduce the error until now, but I will try to do so this evening (beware of time zone differences). I’ll post the results here for you as soon as possible.

    It is magically working now. Perhaps a Facebook issue?

    I keep getting this error:
    “Facebook returned an error: Invalid user or page ID.”

    Nevermind. I had to find a way to get my actual id instead of shortname FB had replaced the id# with a while ago. Thanks for the confusion!

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Plugin: Facebook Page Publish] Can't Connect to Facebook’ is closed to new replies.