WordPress.org

Forums

Facebook
[resolved] Just auto posted an Auto Draft (11 posts)

  1. Brayne
    Member
    Posted 3 years ago #

    Just ran a test and this plugin just posted a WP "Auto Draft" on my Fan page.

    Am I missing a setting somewhere? I hope I'm correct that this shouldn't be posting drafts.

    http://wordpress.org/extend/plugins/facebook/

  2. Samuel Wood (Otto)
    WordPress.org Tech Dude
    Plugin Contributor

    Posted 3 years ago #

    I don't see how that's possible, actually. The code explicitly only posts things when their post_status is "publish". If you hit the publish button, then it's going to publish it, basically.

  3. Brayne
    Member
    Posted 3 years ago #

    So I Published a test 'aside' and then this showed up.

    https://www.facebook.com/PorchSittersUnion/posts/402957779756625

  4. Brayne
    Member
    Posted 3 years ago #

    Weird. I've used your SFC and I've never seen this.

  5. mattkelly
    Member
    Posted 3 years ago #

    I can't reproduce on my own blog. Plus, as Otto said, this seems like it would be impossible.

    If you have more reproduction steps, let us know. Thanks

  6. Samuel Wood (Otto)
    WordPress.org Tech Dude
    Plugin Contributor

    Posted 3 years ago #

    Did you not give the post a name? I can see it getting the default name if you didn't give it one, perhaps.

  7. Brayne
    Member
    Posted 3 years ago #

    Weird.

    I'm trying to recreate so I can report back exactly how I did it. It works just great. But you can clearly see the "Auto Draft" in that link above. I'm going to monkey around this weekend and take a look at all of the revisions log of that particular post.

  8. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 3 years ago #

    Thanks for the update.

  9. Slowdiveza
    Member
    Posted 3 years ago #

    I noticed the auto draft issues only happens if I leave a post as uncategorised. Thats the only way I can replicate this odd behaviour, with a properly setup category its behaving fine.

  10. patv
    Member
    Posted 3 years ago #

    I'm having the same issue as above. I've just completed the setup so maybe you have to give it abit of time before it works properly - i've tried setting a category on my posts but i still get the auto-drafts.

    Slowdlveza, Brayne. Have you been able to reproduce the problem again since? I'll let you know if it resolves itself.

  11. patv
    Member
    Posted 3 years ago #

    Found this useful thread on how to remedy this problem (if even temporarily until the next update). Fixed this issue for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Facebook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic