Support » Plugin: Facebook » [Plugin: Facebook] Headers already sent error

  • Resolved BluePanda

    (@bluepanda)


    On my website (non-wordpress pages) I have a recent posts feed showing. That part works fine, but I am getting the error

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/bluepand/public_html/index.php:25) in /home/bluepand/public_html/blog/wp-content/plugins/facebook/includes/facebook-php-sdk/facebook.php on line 39

    The code I use to grab the recent posts is

    <?php
    require('blog/wp-blog-header.php');
    ?>
    
    <h3>Latest articles</h3>
    				<div>
    					<?php query_posts('showposts=3'); ?>
    <?php while (have_posts()) : the_post(); ?>
    <p><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><?php the_title(); ?></a></p>
    <?php endwhile;?>
    				</div>

    Any ideas on how to solve this? You can view the problem at http://blue-panda.co.uk (right bar of index page)

    http://wordpress.org/extend/plugins/facebook/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Samuel Wood (Otto)

    (@otto42)

    Look at the end of your /home/bluepand/public_html/index.php file. You may have a blank line or something after the closing ?> line.

    Just remove the ending ?> and that will likely fix it.

    BluePanda

    (@bluepanda)

    Fixed it. Just moved the require to the top of index, I guess a session was being set by it from the facebook plugin

    Plugin Contributor Matt Kelly (Facebook)

    (@mattwkelly)

    Thanks for following up

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Facebook] Headers already sent error’ is closed to new replies.