[Plugin: Facebook / Facebook comments for wp] Not showing mod tools (5 posts)

  1. pressenterdesign
    Posted 3 years ago #

    Hello guys!

    This is my first entry here, but i'm writing to you in quite a despair.

    I've been using the facebook plugin for quite some time now, mostly for comments and everything seemed to be working just great, but recently we've had a server change. Previously we had a nginx based server, and now it's apache. The clean permalinks do not work too well with nginx so i always had the default links on our WP blog, but now with apache i've decided to make a switch to clean permalinks.

    To the point. Any facebook comments plugin does not work now. I mean the comment box shows up, but i don't have the moderation tools available and no new comments show up in the facebook comments moderation area, and also old comments disappeared, i mean they are still shown in the facebook comments moderation area, but do not show on my website.

    Ok, time for some screenshots.

    This comment right here:


    should be shown under this post:


    but as you can see no moderation tools, no comment.

    The appid, administrator settings all seem to be ok:


    If someone could be so helpful and look into this it would be really great!

    Take care and thank you in advance

  2. aendrew
    Posted 3 years ago #

    This is what I did:

    a. Install Yoast's WordPress SEO plugin. http://yoast.com/wordpress/seo/
    b. Set up Facebook OpenGraph stuff under wp-admin -> SEO -> Social (wp-admin/admin.php?page=wpseo_social). Make sure to link either app or a valid admin user account.
    c. Add the following to your theme's functions.php file:

    * OpenGraph stuff is now handled by Yoast.
    * This removes Facebook's broken use of its own technology.
    add_action('wp_head', 'remove_fb_og_stuff', 0);
    function remove_fb_og_stuff() {
    remove_action( 'wp_head', 'Facebook_Open_Graph_Protocol::add_og_protocol' );

    Et voilĂ . It's absolutely ridiculous Facebook's 1st-party plugin doesn't follows Facebook's own API documentation when implementing OpenGraph metatags. Note that this has taken me *ages* to figure out at this point.

  3. Ankur Gupta
    Posted 3 years ago #

    Hi aendrew,

    Just wanted to confirm is your code still working?

    As i tried removing facebook plugin open graph tags, but its not wroking for me.
    I stil have duplicate og tags on funnychutkule

  4. aendrew
    Posted 3 years ago #

    It seems you have the right kind of OG tags now -- the meta ones instead of the ogp.me ones.

    If it's still not working for you, it must be something else -- sorry I can't be more help!

  5. Ankur Gupta
    Posted 3 years ago #

    I have right tags now bcoz as of now i commented the following line in facebook plugin's facebook.php file

    // add_action( 'wp_head', array( 'Facebook_Open_Graph_Protocol', 'add_og_protocol' ) );

Topic Closed

This topic has been closed to new replies.

About this Topic