WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Facebook] Disable "View Comments"

[Resolved] [Plugin: Facebook] Disable "View Comments"

Viewing 15 replies - 1 through 15 (of 21 total)
  • ?

    Plugin Contributor Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    Don’t turn on the comments piece, perhaps?

    mattkelly
    Member

    @matthwkgmailcom

    Yes, just disable it on the Settings page in the WordPress admin dashboard.

    What I am referring to is on the homepage, it replaces the default “2 comments” line and puts and ugly icon with Facebook style text.

    Plugin Contributor ngfeldman
    Member

    @ngfeldman

    If you mean that you want to have the comments info not be shown on the homepage when the comments are enabled, there’s no way to do that right now. Thanks for the idea, though. We’ll try to add this in to the next version.

    That’s exactly what I meant!!! Thank you!!

    atlasliberty
    Member

    @atlasliberty

    I would like to see this gone, too.

    Plugin Contributor Colm Doyle
    Member

    @colmdoyle

    I’ve a pull request on deck to provide this option for you.

    Does anyone know how to style the FB “view comments” link? It sits out of line with my tag links, I just want to move it a little (here’s my site)

    I dont want it there at all either but for now if i could just try and at least make it look better..

    thanks

    wwwebconcepts
    Member

    @wwwebconcepts

    You should be able to disable comments on selected pages and posts by deselcting the Allow Comments checkbox on the edit page or post page. Unforunately, the current version of the facebook plugin doesn’t work with this feature. If you uncheck the box you get the default WP comments box below the fb Like button and rec bar. Even more unfortunately, the developers have shown themselves uninterested in addressing this issue. I rolled my fb plugin installation back to the 1.02 release in which this feature works correctly. That is only shows the fb social plugin if the Allow Comments box is selected which is the most desirable. I don’t need a like button or a comments on my support pages and Contact form. That’s just silly.

    wwwebconcepts
    Member

    @wwwebconcepts

    BTW: here’s how to remove the “View Comments” link. It will require you to edit your theme’s content.php file. (It’s a good idea to make backup before proceeding.)

    Open content.php. You should see line something like this:

    'after' => theme_get_metadata_icons( 'category,tag,comments', 'footer' )

    Simply remove the elements you don’t want. In your case comments. Also remove the comma–if there is one–separating the list of elements. And make sure you retain the single quotes.

    Hope this helps.

    wwwebconcepts – how do I revert back to the 1.02 release?

    wwwebconcepts
    Member

    @wwwebconcepts

    I have copy of the v1.0.2. You would have to upload it to your plugins directory. wayne@ebconcepts.com

    Plugin Contributor Colm Doyle
    Member

    @colmdoyle

    If you’re familiar with git, you can also get the source code from the GitHub repo and roll back to 1.0.2 from there.

    wwwebconcepts
    Member

    @wwwebconcepts

    Any plans to fix the bug which prevents hiding the comments box on selected pages? I’ve posted about this issue several times and there have been several update releases but none which addressed this issue.

    I also tried using the Facebook system to eport the bug, but that was just frustrating.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] [Plugin: Facebook] Disable "View Comments"’ is closed to new replies.