WordPress.org

Support

Support » Plugins and Hacks » Facebook Comments » [Resolved] [Plugin: Facebook Comments] Not working in IE

[Resolved] [Plugin: Facebook Comments] Not working in IE

  • I’m loving this plugin, and in my opinion is much neater and easier to use than other Facebook Comments plugins.

    My only worry is that this doesn’t seem to work in IE? The elements are loaded (.fbcommentbox etc) but nothing is loaded in to them.

    I have embedded the Facebook Comments Social Plugin directly from Facebook (http://developers.facebook.com/docs/reference/plugins/comments) and it works fine across all browsers – however it shows the same comments site-wide, whereas your plugin shows specific post comments which is what I want.

    Hope that makes sense and you can point me in the right direction for getting this working!

Viewing 15 replies - 1 through 15 (of 31 total)
  • Hi there,

    Thanks for the feedback. Can you provide me with a link to one page where the comment box is called twice – once using your manual method and another using the plugin?

    Also, does this happen both with the automatic insertion as well as the shortcode option?

    Hi, thanks for the reply.

    Here’s a link to the development site:
    http://www.keymultimediastaging.co.uk/newlands-blog/?p=7

    Your plugin is the top comments, and the Facebook App is below. You’ll see that the Facebook App has the same comments on both posts.

    But mainly, your plugin doesn’t show on IE, whereas the Facebook App does.

    Thanks for taking the time to check it out. And yep, automatic insertion and shortcode is the same.

    You need to tick the Open Graph and/or XFBML tickbox in the settings. One, or both of them, is needed for IE.

    I hate IE!

    Sorry but that isn’t working either – I have both ticked.

    I hate IE too mate!!

    Hmmm themes must not be adding them in. How well do you know how to develop themes? Long story short this needs to be added within the <html> tag at the very beginning of the template:

    xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml"

    So, the full HTML tag on my site is:

    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">

    Wahey!! It’s works! Thanks matey!

    Which template did you add that to? index? header? footer? single post? page?
    I am also having that problem with ie8

    My header shows this on top::

    <?php
    /**
     * @version   1.0 November 16, 2010
     * @author    RocketTheme http://www.rockettheme.com
     * @copyright Copyright (C) 2007 - 2010 RocketTheme, LLC
     * @license   http://www.gnu.org/licenses/gpl-2.0.html GNU/GPLv2 only
     */
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <?php global $gantry; ?>
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang=""<?php echo $gantry->language; ?>" lang="<?php echo $gantry->language;?>">
    <head>

    Yep, that’s right, in the header.php file

    Change your <html tag so it looks like the pleer’s recommendation. All should work fine after that…

    It is not working for me…… I can not get IE8 to show the facebook comments. this is where I pasted the code at the html tag:
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $gantry->language; ?>" lang="<?php echo $gantry->language;?>"xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">

    Have you tried pasting the exact code I mentioned earlier instead of using PHP within the tag? Does this work?

    My plugin stopped working within the past few days. I didn’t making any changes or at least none that I can remember. The only change was to update my Spam by Math plugin. But it’s not woking for any of my pages.

    @jmacman what happens when you disable that plugin?

    It doesn’t come back. I tired disabling that plugin to see if that was it, but it wasn’t 🙁

    something must have changed. can you provide me with a link? If you don’t want to publish it here, contact me via the plugin homepage

    I was able to make the comments work on IE8 by pasting the code in the single post.php file

    <html xmlns:og="http://ogp.me/ns#" xmlns:fb="http://www.facebook.com/2008/fbml">

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] [Plugin: Facebook Comments] Not working in IE’ is closed to new replies.
Skip to toolbar