Support » Plugin: Facebook Comments for WordPress » [Plugin: Facebook Comments for WordPress] ERROR! Invalid application ID

Viewing 15 replies - 1 through 15 (of 22 total)
  • same issue here!

    Tried deleting the app, creating a new one, deleting plugin, re-installing etc… no use !

    Ditto that. Plugin is not accepting the app ID.

    same problem here.. and it shows some other comments from somewhere else ..

    Facebook Comments for WordPress – “ERROR! Invalid application ID”! It seems nobody is working on this issue. There must be thousands of websites having this problem right now.

    Same here, thou people are able to comment and it just works the way it’s supposed to be working, I find it very odd. Well in the front end it’s working just fine but in the back end I’m not getting any notification so I don’t know when people are commenting…

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    @diegocerezom, instead of bumping up these weeks old conversations, start your own thread and provide some details regarding what you’ve done, how you’ve set it up, you site URL, etc.

    Plugins and Hacks

    Ok, no worries, Jan Dembowski I’ll keep it in mind for my future postings, I didn’t think that a few weeks would make this post as an old one, may I suggest that post be treated as resolved or unresolved? making new posts about an already discussed topic makes the forums a difficult place to get answers, as you see there at least 5 o 7 threads with the same question and same answers, yea one thread…

    Thanks anyway! hope you have great day!

    Hi, I’m also having the same issue. I have just loaded this on one of my client’s sites and every time I try to activate it, I get the following error on the configuration page: “ERROR! Invalid application ID. Please double check to make sure it is correct. Note that this is not the same thing as your Facebook user ID”

    I have checked and rechecked and it is the correct APP id. I even tried creating a new app, no luck. WP FB Like is loaded on the site, but I disabled it. No change. Using WordPress v 3.3.1. I have disabled this plugin for now, until I can figure out or find out why the app id isn’t being taken. Thanks.


    I downloaded this plugin about two weeks ago and let it run without the App for a while – because I’m just learning to be ‘tekky’ and thought configuring the app would be too hard for me!.

    Initially, the steps I took was to delete all other Facebook icons – then using Jetpack’s ‘sharing’ section from dragged and dropped the social tabs wanted.

    I also disabled the WP comment box as per the instructions. The FB Comments box worked, but without the app it wouldn’t show the ‘comment moderation area’.

    So I followed the instructions for the app and used ‘Heroku’. The only issue I found was that when setting it up the boxes get automatically filled in and one had to delete that info and replace it with one’s own website address. [It was during this process that a notice came up saying there was an error.]

    I followed through with the instructions and now the comment box moderation area is active. However, the comment box does not show up in IE at all. It shows fine in Chrome.

    I’ve just written about the above in case it jogs a memory or helps someone to get there’s working better.

    ‘Diegocerezom’ is sounds as though you have not configured the app.

    Does anyone know why it doesn’t show up in IE?

    With thanks


    I followed the link posted by PSorger and found out that there is a problem with it showing up in IE.

    Can anyone help. I need to paste a piece of code into my Header.php {in order that the Facebook comments box shows up in Internet Explorer}

    The instructions are: open up your theme’s header.php file and add the following attributes to the <html> tag:

    xmlns:fb=”” xmlns:og=””

    However, when I get to the header.php, the options are more complicated:

    <!–[if IE 6]>
    <html id=”ie6″ <?php language_attributes(); ?>>
    <!–[if IE 7]>
    <html id=”ie7″ <?php language_attributes(); ?>>
    <!–[if IE 8]>
    <html id=”ie8″ <?php language_attributes(); ?>>
    <!–[if !(IE 6) | !(IE 7) | !(IE 8) ]><!–>
    <html <?php language_attributes(); ?>>

    Do I add the code to each straight after the html id?

    With grateful thanks for a reply!


    I posted elsewhere and got the answer. In case someone else has this problem you insert straight after the FIRST close php tag BUT you add a space. And it goes into all of them.

    In my opinion, no need to use this plugin anymore. Go here:

    Build a link for your site (use HTML5), then substitute the URL with <?php the_permalink(); ?>

    Put the javascript call after the body tag and you’re all set.

    invalid application id too, but it’s not working…..

    If IE doesn’t work, make sure you are calling the XFBML version as HTML5 won’t work. And Invasive said it, make sure you go there and create the new code FB is creating for comments.

    Having the “Invalid Application” issue as well…please address.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Facebook Comments for WordPress] ERROR! Invalid application ID’ is closed to new replies.