Support » Plugin: Facebook AWD All in one » [Plugin: Facebook AWD All in one] V1.4 issues

  • Resolved iburley7

    (@iburley7)


    I’ve just updated to v1.4 through WP updates, and I am now having some difficulties!

    On the settings screen, I get a ‘login with Facebook button’, but clicking it does nothing (I’ve tried in both Safari and Chrome). As a result of this I cannot now use the publishing features.

    The ‘connect with facebook’ button on the login screen does not do anything either.

    The ‘like’ button, comments box, and like box sidebar widget do not appear on any pages or posts.

    I have gone through the settings to make sure the features are turned on as they were prior to the update (having to do this was frustrating, having taken a lot of time to set the plugin up once!).

    I have created a very simple opengraph object, which I have set for all types of page.

    When running a number of pages and posts through the Facebook Developer debugger, the only return which is unexpected was the og:image, which seems to return my app icon rather than an image from the post.

    I have tried my opengraph object with %IMAGE% in the image URL box, and with a blank entry, and with Auto load image attachments set to both yes and no, but the debugger still returns my app icon rather than an image from the page or post.

    Any advice greatly received! (or a link for the last version 1.3.x.x…)

    http://www.6harrow.org

    http://wordpress.org/extend/plugins/facebook-awd/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author AHWEBDEV

    (@ahwebdev)

    On the admin notice I said you will have to reconfigure the settings.

    If you want to use the featured image, you must set the auto load images to On. Or use the %IMAGE% only for posts and pages.

    You must set an image manually for your homepage(if archives) or archives pages.

    For the button on the login screen YES you find a BUG.
    But in the admin area it works ?
    I will check this part.

    Does it have to use a featured image now?

    In the previous version %IMAGE% would pick up the first image in the post if no featured image was used – and currently I am seeing my facebook app icon in the og:image tag in the debugger, not sure why it is picking that up?

    The login button does not work in the admin area either for me.

    Any idea why the like button and comments box are not appearing on post pages – definitely set to do so on the plugin pages?

    Also, the like box I have set up in the side bar is not showing.

    I’ve also got this message in the debugger:

    “fb:admins and fb:app_id tags are missing. These tags are necessary for Facebook to render a News Feed story that generates a high click-through rate.”

    Not sure where to enter the fb:admins and fb:app_id to clear this message.

    Plugin Author AHWEBDEV

    (@ahwebdev)

    fb:admins and fb:app_id will be added tonight.

    Can you check with firebug if there is a javascript error in admin area that can break the login button ? Maybe some plugins conflict…

    Can you paste log result here ?

    About the image, i will check tonight.

    I was just typing an update when your response came through 🙂

    I will try opening the error console in Safari, but I’m no expert so you may need to point me in the right direction if what I paste in isn’t useful. I will post the results separately.

    UPDATE –

    Setting a featured image for a post does make %IMAGE% return a correct og:image tag. Will it be possible to make this work for the first image in the post as well, like the previous version did, or will we always have to use a featured image?

    Could it be that I am not seeing the like button, comments box and like box widget as I am not signed in?

    /**
     *
     * @author alexhermann
     *
     */
    var AWD_facebook = {
    
    	FBEventHandler : function ()
    	{
    		if(awd_fcbk.FBEventHandler.callbacks){
    			jQuery.each(awd_fcbk.FBEventHandler.callbacks,function(index,value){
    				var AWD_actions_callback = window[this];
    				if(jQuery.isFunction(AWD_actions_callback))
    					AWD_actions_callback(this);
    			});
    		}
    	},
    
    	callbackLogin : function(response,redirect_url)
    	{
    
    		var redirect = '';
    		if(response.authResponse){
    			if(!redirect_url){
    				window.location.replace(awd_fcbk.loginUrl);
    			}else{
    				redirect = "?redirect_to="+redirect_url;
    				window.location.replace(awd_fcbk.loginUrl+redirect);
    			}
    		}
    	},
    
    	connect :function(redirect_url)
    	{
    		FB.login(
    			function(response){
    				AWD_facebook.fbConnected = true;
    				AWD_facebook.callbackLogin(response,redirect_url);
    			},
    			{
    				scope: awd_fcbk.scope
    			}
    		);
    		return false;
    	},
    
    	logout : function(){
    		window.location.href = awd_fcbk.logoutUrl;
    	},
    
    	fbConnected : false,
    
    	isFbConnected : function(){
    		FB.getLoginStatus(function(response) {
    			if (response.status === 'connected') {
    				AWD_facebook.fbConnected = true;
    				AWD_facebook.access_token = response.authResponse.accessToken;
    			}
    		});
    		return AWD_facebook.fbConnected;
    	},
    };
    
    jQuery(document).ready(function($){
    	//add usefull tool for creating connect button by hand.
    	$('.AWD_facebook_connect_button').live('click',function(e){
    		e.preventDefault();
    		var redirect = $(this).data('redirect');
    		AWD_facebook.connect(redirect);
    	});
    });

    Is this what you were after?

    I also get the message in the error console:

    “Facebook_awd.js

    Reference issue
    Can’t find variable: FB”

    Plugin Author AHWEBDEV

    (@ahwebdev)

    Reference issue
    Can’t find variable: FB”

    You get that only on the login page no ? in admin too ?
    Social plugin should works. look here http://www.ahwebdev.fr it uses the 1.4 and fb plugins are working.

    I am having the same Login button troubles as well. Sometimes it shows up and sometimes it doesn’t. When it does show up it often doesn’t launch the login app.

    I have noticed that the failure of the login button is also directly correlated to the “Like” button showing up at the top of posts. Either they both show up or NONE of them show up.

    If also found that the problem is intermittent. Sometimes if you refresh the page a few times it will work.

    The code and the message in the error console were taken after clicking the button on the Facebook AWD admin page on the dashboard.

    I’m seeing the login button consistently in the sidebar widget, the login page, and the admin page on the dashboard, but they all appear to do nothing when clicked.

    I never see the like button at the top of posts, even though it is turned on.

    Plugin Author AHWEBDEV

    (@ahwebdev)

    Are you both using html5 or xfbml buttons ?

    I was using html5. I have just changed the like button to xfbml – no change noticed.

    I do not have the option to change the login button between the 2 standards.

    Plugin Author AHWEBDEV

    (@ahwebdev)

    Can you try to download the version from gitHub ? i update some line of code…
    https://github.com/AHWEBDEV/Facebook-AWD

    I can’t get the gitHub version to activate:

    Fatal error: Cannot redeclare class AWD_facebook in /home/iburley7/6harrow.org/wp-content/plugins/AHWEBDEV-Facebook-AWD-cd18b7c/AWD_facebook.php on line 20

    Sorry – my fault, somehow had v1.4 and v1.4.1 installed, and 1.4.1 wouldn’t activate as 1.4 was activated…!

    Plugin Author AHWEBDEV

    (@ahwebdev)

    Ok and the folder of the 1.4.1 is named “facebook-awd” ? this is important…

    So after activation did you see difference ?

    Sorry, no difference.

    I have removed 1.4 and uploaded 1.4.1 to “facebook-awd” in wpcontent/plugins

    Uncaught ReferenceError: FB is not defined facebook_awd.js:38
    AWD_facebook.connect facebook_awd.js:38
    (anonymous function) facebook_awd.js:72
    f.event.dispatch jquery.js:3
    f.event.add.h.handle.i jquery.js:3
Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Plugin: Facebook AWD All in one] V1.4 issues’ is closed to new replies.