Support » Plugins and Hacks » Facebook AWD All in one » [Plugin: Facebook AWD All in one] Image post not showing

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author AHWEBDEV

    (@ahwebdev)


    If the post is not showing the right image, verify your settings if the URL image is correctly set to %POST_IMAGE%, then go to the debugger on facebook to clear cache.

    The only thing that changed is the “atom image”.
    It’s the image of your application on facebook. if the plugin use it, it’s because he can’t find an image on the post.

    sorry for being a noob but where do check the url image %post_image% ??

    In your plugin settings, facebook app settings?

    Plugin Author AHWEBDEV

    (@ahwebdev)


    In the OpenGraph settings in the plugin, in the “tags” section there is a field “Image URL”, you should use the magic pattern %POST_IMAGE%

    The OPengraph is not automatic, you must activate it in the plugin, and fill the form.

    Read the wiki to help you configuring it.
    http://trac.ahwebdev.fr/projects/facebook-awd/wiki/How_to_use_OpenGraph

    I tried to set the open graph as best i could, ran the debugger and got this error.

    Object Invalid Value: Object at URL ‘http://www.tlg.be/?p=1812’ of type ‘article’ is invalid because the given value ‘117989574920354’ for property ‘fb:admins’ could not be parsed as type ‘fbid’.

    i also notice that under the FB comment box i get a warning:

    Warning: http://www.tlg.be/ is unreachable.

    I think something is really messed up here.
    i never had to do this before, like plugins or fb comments plugins just worked when you activated them. :p

    Plugin Author AHWEBDEV

    (@ahwebdev)


    Object Invalid Value: Object at URL ‘http://www.tlg.be/?p=1812’ of type ‘article’ is invalid because the given value ‘117989574920354’ for property ‘fb:admins’ could not be parsed as type ‘fbid’.

    You have to set your personal facebook user ID, in the field “Admins ID” not a facebook page id.

    i also notice that under the FB comment box i get a warning
    Warning: http://www.tlg.be/ is unreachable.


    This warning do not come from the plugin
    . This mean Facebook cannot access your website. Verify that your server is not in local, or behind a firewall or a robots file that add facebook restriction.

    I got the right Admin ID now and when i like a post the image is showing on my FB wall. 🙂

    I still get an error when i like it and its says:

    The app ID “1361460725” specified within the “fb:app_id” meta tag was invalid.

    That app ID is from my previous app, i created a new one and i updated the ID’s in all the opengraphs and plugins. Still don’t know why it is still looking for that app id??? Is there another place i need to change the app ID?

    Plugin Author AHWEBDEV

    (@ahwebdev)


    App ID can be specified in general settings, in general openGraph settings, and on each post that you redefined.

    I am really having an issue with the same thing. Two blogs now, once I’ve began to install plugins that link to Facebook features, now leave me without the option of images featured from the article. It is highly un-intuitive to figure out these Facebook apps and the Plugins on WordPress. I’m trying, but there isn’t a whole lot I’ve yet found that is in language understandable, and Facebook has the worst interface in giving a straightforward explanation on things associated with creating apps and how to make them function.

    I’ve had a blog that until today, gave me the ability to preview the image from the article that would be posted, but now that feature is gone after putting in my AppID/API Key and the App Secret. What I put in for the “Admins IDs (facebook)” field is not something I’ve yet discovered to be given to me within my Facebook app page.

    Plugin Author AHWEBDEV

    (@ahwebdev)


    Admins IDs (facebook) is your personal facebook ID.
    It’s a numeric ID.

    To get it, activate facebook connect, then login with facebook,
    In the settings of the plugin in the right sidebar, under the profile section, your id is showing up here.

    To Show an image from a post you have to activate openGraph settings.
    (if you update you have to re setup your tags)
    in the general settings or individually on each post or page.
    To use the featured image you must set the value %POST_IMAGE% in the related field in the opengraph settings.

    Then each time you change those settings, you must go to the debugger on facebook to clear the cache and update your data.

    now leave me without the option of images featured from the article

    I think you have a plugin in conflict, because Facebook awd add the theme support for featured image, if you can’t see it, maybe something is broken.

    Hi,
    I just installed plugin, which gave the following error and now I cannot access my dashboard or anything behind the scenes. PLEASE HELP!

    error
    Fatal error: Call to undefined method stdClass::add_help_tab() in /home/tomleen/public_html/wp-content/plugins/facebook-awd/AWD_facebook.php on line 495

    Plugin Author AHWEBDEV

    (@ahwebdev)


    @tky

    1. Create your own thread…
    2. Read the configuration required when you install or update a plugin.
    This error come from wordpress that is not up to date.
    The last version required the 3.3.1 of WP.

    If you can’t update WP, Downgrade to the previous version of the plugin.

    ok, thanks very much for your response and apologies for wrong thread

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Facebook AWD All in one] Image post not showing’ is closed to new replies.