[resolved] App doesn't ask for permission (4 posts)

  1. DigitalEssence
    Posted 3 years ago #


    bit of a long story so let me try and explain what I have done...

    I have the app (Version 1.0.2) installed on WordPress (3.4.1) and it was working fine. I could create a post and it would publish to the specified fan page.

    I then noticed that it also published to my personal Timeline and I wasn't happy with the wording as I had given it a poorly worded Display Name and I therefore wanted to change it.

    Instead of what I now assume would have been the easy option of just changing the Display Name, I went into my FB Account Settings -> Apps and removed the app from the list of authorised apps.

    I then deleted the app from developers.facebook.com, created a new one with the correct Display name and sensible Namespace and configured the WordPress plugin settings but whatever I do I can't get the app to request permissions on my FB account and therefore the "Publish to fan page" option is showing as disabled.

    Any and all advice is appreciated,


    Hedley Phillips


  2. DigitalEssence
    Posted 3 years ago #

    I've just spotted the thread: "Publish to fan page setting Disabled" and am wondering if I also have the same issues. Will try the Github version just now.

  3. DigitalEssence
    Posted 3 years ago #

    Still the same.

    My App still doesn't ask for permission within Facebook and isn't showing in my list of apps. Is there a way to force it to request permission?

  4. DigitalEssence
    Posted 3 years ago #

    Marking as resolved...

    I made another coffee and sat and read through more support posts and came across this one:


    where martong mentions Deleting all entries fb_data in Table wp_usermeta having the FB connection information.

    This has worked.

    I also notice that this issue is being worked on via https://github.com/facebook/wordpress/issues/196

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Facebook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic