WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Facebook] API Error Code 191

[Resolved] [Plugin: Facebook] API Error Code 191

  • Hi. I seem to be having the same issue that a number of people have been having. However none of their fixes seem to work for me.

    this is the complete error message:

    API Error Code: 191
    API Error Description: The specified URL is not owned by the application
    Error Message: Invalid redirect_uri: Given URL is not allowed by the Application configuration.

    If someone could help me out I’d appreciate it.
    Thanks

    http://wordpress.org/extend/plugins/facebook/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hello

    I am having the exact same issue, with one possible wrinkle – my Facebook account is not on ‘Timeline’. Is this required for the plugin to work?

    Plugin Contributor Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Issue has nothing to do with timeline, you have your app settings setup incorrectly.

    See this for more info:
    http://wordpress.org/support/topic/plugin-facebook-api-error-code-191-194

    The reason I got this problem had to do with my MU domain mapping.

    If my site’s URL is http://www.example.com, the ‘real’ site is on example.wordpress.myactualdomain.com. The real site name is what facebook sees and needs to be listed in the site URL’s. It’s at least necessary, not sure if it’s sufficient. I have both the real wordpress DNS name and the public DNS name listed now, and it’s working.

    Thanks bill_mcgonigle, but although I profess to be quiet computer literate this example.wordpress.myactualdomain.com does not make sense to me.
    My url is http://www.mysticalvampirevixens.com so if I understand what you say then I should have http://www.mysticalvampirevixens.wordpress.mysticalvampirevixens.com as the URL? and then just http://www.mysticalvampirevixens.com? If so, I have tried it and it doesn’t work.
    Thanks also to Otto Tech Ninja I have read through that link and again it makes no sense to me.
    I’m sorry that I appear to be totally clueless on this one.

    No, the second domain would be different. Are you using WordPress MU with domain mapping and DNS subdomains?

    I have no idea except that I am using WordPress 3.4
    My website is hosted by Just Host. Thats about all I know.
    My wordpress and site address are both the same in the settings. Thats about all I can find out.

    Your site resolves back to just104.justhost.com. It’s possible you’d have to add that to the site addresses – I’m not sure how they use that data on the Facebook side.

    So using that information my site URL should be
    https://www.mysticalvampirevixens.wordpress.just104.justhost.com
    So I have replaced all URL’s with the above and the error code is still appearing. I have re read through both this thread and the one that Otto links to and I still cannot figure it out.

    No, it doesn’t appear that your hosting provider uses the DNS scheme as mentioned above. You shoud probably contact them as only they would know.

    No worries. I’ll contact their support team who I hope can help me out.
    Thanks for your help, its much appreciated.

    Bill,

    I am having the same problem as you.

    I started two different facebook apps for two different mapped domains in a Multisite install.

    I keep getting this error in reference to my mapped domains.

    I am not using DNS subdomains. I am using this format for my domains before they are mapped: http://www.xxxxxxx.com/sitename

    Facebook won’t let me input this format into the app domain or site url boxes.

    I’m not sure what to do!

    Justin

    Plugin Contributor Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    The 191 error is very, very simple to solve, actually.

    Look at your browser. See what’s in your URL bar? Whatever you see when you are looking at the home page of your site is what you must give to the Facebook Application.

    My site is http://ottopress.com. So that’s what I told the application.

    Note that my site is not “OttoPress.com”, nor is it “http://www.ottopress.com”. You have one URL, and you can’t guess at it, or make it up. It’s in the URL bar of your browser. It’s the only *real* URL of your site. Use it properly, don’t change the caps, don’t add non-existent www’s to it.

    Note: If the back-end of your site has a totally different domain than the front end of your site, then you must give the Facebook Application BOTH domain names in “App Domains”, but only the main site URL in the “Site URL” field.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: Facebook] API Error Code 191’ is closed to new replies.