Support » Plugin: EZPZ One Click Backup » [Plugin: EZPZ One Click Backup] Fails for me for both DB and File backup

  • Resolved GeoffreyG


    I installed and tried the plugin and everything looked good, but when I tried to do a one click backup, I get the following:

    First we need to gather some information about (My Site)
    Don’t worry, sit back and I’ll do all the work.
    Get the required database information.
    DB Host: (My Host) ✔OK DB Name: (My DB) ✔OK
    DB User: (My User Name) ✔OK DB Password: [Hidden] ✔OK
    Website URL: (My URL) ✔OK
    Get Full WordPress Path: (My Path) ✔OK
    Now let’s get the database contents and create (Site Name)_2011-02-28.sql
    Archiving Your Database
    Warning: mkdir() [function.mkdir]: File exists in (My Path)\wp-content\plugins\ezpz-one-click-backup\functions\ezpz-ocb-functions.php on line 6

    Warning: exec() [function.exec]: Unable to fork [mysqldump -p –user=(My User Name) –password=(My Password) –host=(My Host Name) –add-drop-table (My DB) > (My File Path)_2011-02-28.sql] in (My Path)\wp-content\plugins\ezpz-one-click-backup\functions\ezpz-ocb-functions.php on line 40
    EZPZ OCB was unable to backup the database. This is usually due to mysqldump being disabled by your server. EZPZ OCB will now continue the backup process however it will not be possible to make or include a database file with EZPZ OCB.

    Finally we’ll zip your entire WordPress installation and the database into (My Site)_2011-02-28.tgz
    Warning: exec() [function.exec]: Unable to fork [tar czf (My File Path)_2011-02-28.tgz –exclude “F84ezpzyGZ*” –exclude “F84ezpzyGZ” ../../(My Path)] in (My Path)\wp-content\plugins\ezpz-one-click-backup\pages\ezpz-ocb-backup.php on line 137
    EZPZ OCB was unable to complete your backup. This is usually due to a server issue such as the process timing out or needed functions such as exec, mkdir, etc being disabled on your server. Please try decativating and reactivating EZPZ OCB then run the backup again. If the problem persists EZPZ OCB is probably incompatible with your server. Sorry…

    Any idea’s on this problem? I tried deactivating and reinstalling the plugin, but without success. Please let me know if you have a fix, thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author EZPZSolutions


    Are you running on a Linux server? “Unable to fork” appears to be mostly associated with Windows servers. (See Google results) EZPZ OCB is not compatible with Windows servers.

    If you are on a Linux server it appears mkdir and exec may have been disabled by your hosting provider.

    Hello EZPZSolutions,

    Thanks for the follow up. Yes, that is the case, I am running WordPress in a Windows environment…and it sounds like the EZPZ One Click Backup plugin this won’t work that case. Hmm, just a suggestion, but you might want to post that on the Plugin homepage at, that fact was not very clear to me until you mentioned it. So, too bad for me I guess…and again thanks for the follow up…


    Plugin Author EZPZSolutions


    It is stated under the description tab.

    Like most applications EZPZ OCB has certain limitations and requirements. First and foremost, EZPZ OCB only works on Linux servers running PHP 5 and above…

    We will include a pre-installation test in future releases which will halt the installation and issue a warning if it’s on a Windows server or the functions exec or mkdir have been disabled by the hosting provider.

    I am having problems extracting the file and uploading it to my wordpress blog. I even got a tech dude to try do this as they are switching over my data and stuff. Whats the deal with it. I am on a linux server too.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: EZPZ One Click Backup] Fails for me for both DB and File backup’ is closed to new replies.