Support » Plugins and Hacks » [Resolved] [Plugin: EZ Staff List] Fatal error: Class 'table' not found in

[Resolved] [Plugin: EZ Staff List] Fatal error: Class 'table' not found in

  • I have some problems with EZ Staff list plugin.

    I’am reinstall plugin (after deleting plugin) and i get some errors on [staff_list] page and everythere on wp-admin>Staff mgt

    1. On [staff_list] page i see this error:

    Fatal error: Class 'table' not found in /home/administr/domains/administravimas.lt/public_html/wp-content/plugins/ez-staff-list/plugins/staff_management.class.php on line 287

    2. On wp-admin page I see this error:

    Staff mgt
    Fatal error: Call to undefined function xml_transform() in /home/administr/domains/administravimas.lt/public_html/wp-content/plugins/ez-staff-list/framework/core/structure/objects/element.class.php on line 140

    Add staff
    Fatal error: Class 'form' not found in /home/administr/domains/administravimas.lt/public_html/wp-content/plugins/ez-staff-list/plugins/staff_management.class.php on line 119

    Staff members
    Fatal error: Class 'rs_list' not found in /home/administr/domains/administravimas.lt/public_html/wp-content/plugins/ez-staff-list/plugins/staff_management.class.php on line 190

    That’s the problem?


Viewing 15 replies - 1 through 15 (of 21 total)
  • I am also getting same error. please help.

    Plugin Author Luke


    Sorry guys for the delay… I sure wish I would get an email notification when someone makes a comment on my plugin…

    Anyway, see this video here: http://screencast.com/t/GSwMC2Rt


    Plugin Author Luke


    I just found where I can subscribe for the ez-staff-list tag 🙂 LOL

    Same problem for me. Lucas’s screencast isn’t loading for me. What did it say??

    Okay. I haven’t fixed this, yet but think I’ve figured out the problem. For me I started getting the above error after migrating to a new server.
    The include that was failing was in the following condition in phplitefw.inc.php:

    // If proper extensions are loaded, load XML transformation plugin and record set list class
    		if ($this->xml_ext_loaded) {
    			echo ' YES, xml extension is loaded ';
    			if ($this->mode == 'litefw') {

    So, apparently the new server doesn’t have those extensions.

    Plugin Author Luke



    Yes, you would be right.. most likely your new server does not have DOM XML or XSLT processor extensions enabled.

    My screencast basically mentioned to look for common files which are supposed to be there..

    Nearly all PHP 5.3 + installs come with both of those enabled already. I run this framework on several different OS as well including CentOS, Fedora, Mac OSX, etc.

    I assume you are on a shared hosting environment? Your hosting provider should not have any problem enabling those extensions for you.


    On Debian I was able to fix the error, from the root console on the server, with:

    apt-get -y install php5-xsl && /etc/init.d/apache2 restart

    Guys I have another problem, but thought my problem may relates to the above problem, when I upload the plugin and activate it, I can see the Add Staff form and Staff Members is showing good and working properly. But after one or two day when I check back both the screens are scattered. Even I can’t find the buttons. When I view the source of the Add Staff form I can see they are not rendered properly. It looks something like…

    <form name="" action="/perfecttouch/wp-admin/admin.php?page=edit_staff_member.php" method="post"><data><headers>
    	<data_1_0><input type="hidden" name="staff_id" value="" />
    	<data_1_1><input type="hidden" name="action" value="update-staff-member" />
    <elements><row><form_element colspan="1"><label>First Name</label>
    <form_element colspan="1"><input type="text" name="staff_first_name" value="" size="20" />

    But if I upload the plugin again, everything is fine. Please help me with this.


    Plugin Author Luke


    Hmm, that is strange. You are not getting any other errors?

    Typically if you see something like that, XSLT may not be enabled. But if that was the case you should be getting an error.

    I know a lot of times display errors are off.

    Can you put this at the top of the ez-staff-list.php file (just above where the framework is included):

    ini_set('display_errors', 1);
    * Start the framework object
    if (!class_exists('phplitefw_controller'))
        include(dirname(__FILE__) . '/framework/phplitefw.inc.php');

    I was not getting any other errors before enabling error_reporting. But now after enabling it is showing the below error…

    Notice: Error: [phplitefw_controller]::load_plugin(): Plugin "pagination" does not exist! in /home/perthlo1/public_html/perfecttouch/wp-content/plugins/ez-staff-list/framework/phplitefw.inc.php on line 154

    Please let me know what to do now.


    Plugin Author Luke


    That’s interesting. I’m not sure why that is actually being included anyway. I don’t believe that is being used anywhere.

    You can just comment out or remove the line in ez-staff-list.php which looks like this (a few lines under what I wrote above):


    However, that error should not have anything to do with the problem you were having above.

    Do you know what version of PHP you have? Try running this at the top of that same file:


    I have commented the line $pco->load_plugin('pagination'); in ez-staff-list.php and now there is no error.

    I am running PHP Version 5.2.17

    but my problem is still there. only the error that was showing after enabling error_reporting is gone.

    Plugin Author Luke


    Ok, I’m going to put together a quick screencast video to confirm I understand where it is breaking… give me a few minutes.

    Plugin Author Luke


    Please let me know if this video is accurate:


Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] [Plugin: EZ Staff List] Fatal error: Class 'table' not found in’ is closed to new replies.