Support » Plugin: Exports and Reports » [Plugin: Exports and Reports] Other Databases

  • Hey,

    Does the plugin works with other tables then posts? I’ve tried with wp_comments, and i get No items found. The demo reports are generated fine.

    This is the query i’m using:

    SELECT comment_ID,comment_post_ID,comment_author,comment_author_email,comment_author_IP,comment_content FROM wp_comments

    I’m i missing something?



Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Scott Kingsley Clark


    Yes it does. Put your query into the query textarea (like I’m assuming you did) and then add the fields below that you want in the report / export.

    Plugin Author Scott Kingsley Clark


    The demo reports show examples of how the fields are set up, so use that as a guide if you have questions on the field data you’re adding. Other than that, it should work. If at that point it still doesn’t work, let me know and I’ll arrange some time to look at your reports and see what the issue might be.

    Hi Scott,

    Thanks. Ive tryed several different ways. The SQL works fine on PHPmysql but, not in the plugin.

    Any reports i do with the posts database however are fine. For posts, pages, custom types, anything. Even getting related data as well, like Author’s Display Name. But as soon i try to read from another table doen’t do anything.

    Any ideas? Thanks a lot.

    Plugin Author Scott Kingsley Clark


    I’d need to look at your report settings to really know what might be going on here. I’ve never come across a similar issue with any of the sites I’ve done. You can send temporary access to scott [@] skcdev[.] com

    Thanks Scott,

    I’ve sent you the credentials. Thanks a lot

    Plugin Author Scott Kingsley Clark


    It doesn’t look like you’ve got comments in your database table, it looks like IntenseDebate stores them on it’s own server(s).

    There are comments in the database. Intense debate is offnow, so we can see. I’ve tried with other tables as well, users… i know… it’s wierd…

    That is my test site, so no problems in changing stuff…

    i’ve created a new one using Terms… same result…

    Plugin Author Scott Kingsley Clark


    Not sure what to say, the queries themselves return empty results from WP, not an error. If there were an error (I checked for the error when I was in there), it’d be a different story but it’s just empty. You may want to confirm you’re looking at the right database, or perhaps confirm the table prefixes are correct. This issue hasn’t happened for anyone else the same way, so it looks like there might be something else outside this plugin that is causing this.

    Hey Scott,

    Thanks for your time.
    So far I’ve tryed:

    – 2 different hosting companies;
    – Several WP setups. (new and old installs)
    – Different databases and tables;
    – Different prefixes;
    – All other plugins disabled.

    Same thing, no results.

    Out of curiosity, I’ve copied the posts table to another table with a different name in the same db. Works.

    Then I’ve copied the comments table to one i’ve mentioned above (Just replacing all data and keeping the same table name) and changing the table name in the repost query. No results.=(

    You said that the query is not generating an error. I’ve create some reports omitting the table name or the entire query but the only message displayed is “No items found”. Where should i look for that error message? And when?

    Thanks a lot.

    Plugin Author Scott Kingsley Clark


    The error message is hidden right now, but will be visible in a future release. Your issue is very interesting, I’ve never seen it happen before.

    Could I perhaps do some deeper debugging? Can you ensure my WP temporary access is still enabled and maybe send me some FTP details for me to test with?

    I know this was a couple of months ago, Scott, so not sure if anything has happened since, but I just want to confirm that I have the same problem as estevanix.

    If I try to query any table that isn’t “posts”, I get no result. If I use an inner join with “posts” and another table, I get results.

    It seems then that there is something in your code that is requiring posts to be a part of it? Is that the case?

    Anyway, would be great to know if you have made any progress on this with your debugging! Thanks!

    (PS, It’s a great plugin!)

    Plugin Author Scott Kingsley Clark


    @Wzzamoss – What SQL Query are you using that is not working correctly?

    Yes, I wanted to confirm that I’m having the same problem. I’ve spent a lot of time experimenting with every possible combination and cannot get any results from another table. The SQL I’m trying to make work is:

    SELECT post_id,meta_value FROM wp_postmeta WHERE meta_key=’_members_access_role’

    I have specified the (optional?) fields as in the examples with no results. I even tried to return just one column without a WHERE clause and still nothing.

    I think it will be a great plugin but I don’t know what I’m doing wrong. Thanks!

    Plugin Author Scott Kingsley Clark


    Interesting, going to keep checking into this and see if I can get this next update out this week.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Exports and Reports] Other Databases’ is closed to new replies.