Support » Plugin: Exploit Scanner » [Plugin: Exploit Scanner] Error while scanning; will not scan

  • I just downloaded the newest version of Exploit Scanner (1.3). I ran it on a small test WP site, and it ran fine.

    When I tried to run it on my larger site, I get the following error:
    “An error occurred. Please try again later.”

    I reset the upper file size limit to 100KB, that made no difference. I changed it to 20KB (saw this on previous post). I got this error:
    An error occurred:

    {“status”:”error”,”message”:”$this->files was not properly saved as a transient”,”data”:{“files”:””}}

    Any suggestions on how to get this to work would be appreciated.

    [ Please do not bump, that’s not permitted here. ]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Try reducing the batch size to 100 files – I found the scan stalled at 4000 files and returned error message if set higher than 100.
    Other setings: File size 400kB


    Thanks for the advice. I tried setting files to 100 per batch, and I get the following response:

    It said “files Scanned” for about 5 minutes, then “An error occurred. Please try again later.”

    Could the problem be because my site is behind a firewall?


    Firewall shouldn’t stop the plugin working – if it does then it’s very faulty – firewalls are part of web security. the site I’m using it on is also behind a firewall..
    I’ve run this on the live site and a duplicate mirror site on my development server: The locally hosted version runs no matter what I set the file limits and size to: set it to mimic the live server – memmory limit (100MB), entry processes (12) etc and it has never failed. On the live site even with the reduced settings it only works sometimes (discoverred that after posting my original reply)
    Seems to fail when the server gets another reguest – looks like the plugin scan gets interrupted when server is active with other tasks.
    Maybe discuss this with your hosting provider – I’m assuming you are on shared hosting?
    Sorry couldn’t be helpful

    Hi Mikeotgaar,

    Thanks for your feedback.

    We are on our own server. And I am testing this on our sandbox server (which is hosted), so there should not be any activity on that site. I checked the log files, and saw some errors like this:

    PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /wp-content/plugins/more-types/more-types-object.php on line 38, referer: /wp-admin/tools.php?page=exploit-scanner

    Seems like exploit scanner is running the pages, instead of reading the pages. Then I get a timeout error:

    PHP Fatal error: Maximum execution time of 120 seconds exceeded in /wp-content/plugins/exploit-scanner/exploit-scanner.php on line 799, referer: /wp-admin/tools.php?page=exploit-scanner

    I tried adding code to the exploit scanner page to not time out. So it just kept spinning, with nothing happening.

    Any more ideas?

    Possibly conflicting with php settings? set_time_limit ( int $seconds ) max_execution_time ( int $seconds )

    Found something: reduced the number of file scanned to 25 in exploit-scanner.php and now it’s causing an ajax error.



    I had the same problem: “files was not properly saved as a transient”.

    Figured it out that the filelist is too big for mysql. Server responded with this “Got a packet bigger than ‘max_allowed_packet’ bytes”.
    The default value of max_allowed_packet is 1,048,576.
    Maybe you can try to increase the value. (or reduce your files 😉 )

    The strange thing is that even it returns the error above, the plugin scans all your files until it runs into the max_execution_time. The batch limit is not set because paged is not set.

    I just don’t think it works. On to the next one….

    You might want to note my comments here.

    It appears that some versions of PHP may not play well with the code for this plugin. I do recall it working when I was using 5.2, but I know it didn’t with 5.3.19, which I used for quite some time. I just bumped to 5.3.25, and it worked right off. It could have been an Apache memory setting for the mpm, though I doubt that, and the only other thing I’ve changed recently had to do with the TZ string in the environment, as PHP wasn’t getting the correct offset.

    GL HTH


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Exploit Scanner] Error while scanning; will not scan’ is closed to new replies.