WordPress.org

Support

Support » Plugins and Hacks » Exploit Scanner » [Resolved] [Plugin: Exploit Scanner] 0.97 blanks my site

[Resolved] [Plugin: Exploit Scanner] 0.97 blanks my site

Viewing 4 replies - 1 through 4 (of 4 total)
  • update:

    to test the plugin, i tried activating it and the plugins page gave me the following error:

    Parse error: parse error, unexpected T_CLASS in /XXXXXXX/wp-content/plugins/exploit-scanner/exploit-scanner.php on line 346

    i hope this helps.

    Plugin Author Jon Cave

    @duck_

    WordPress Dev

    Thanks for the report. I guess you’re using a host running PHP 4 which doesn’t support abstract classes. If this is the case then the quick fix for now is to remove the abstract keyword on line 346 (leave the rest intact) and comment out line 349 (which reads abstract function run();).

    Plugin Author Jon Cave

    @duck_

    WordPress Dev

    Updated with PHP 4 compability in 0.97.1, sorry for the inconvenience and thanks again for posting.

    However, it should be mentioned that PHP 4 is an end of life product and no longer supported by the PHP Group with the last security fix in 2008.

    php4 support: i know. my host is yahoo and i have asked them several times _when_ are they going to upgrade to using php5. and the standard answer i get is that “yahoo’s customers are happy with php4 so they don’t see any need to upgrade anytime soon”. they’ll sink soon enough if they do not change that point of view or attitude. actively looking for another host that fit my needs.

    thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: Exploit Scanner] 0.97 blanks my site’ is closed to new replies.
Skip to toolbar