Support » Plugin: EWWW Image Optimizer » [Plugin: EWWW Image Optimizer] Two questions about the plugin

  • Resolved Alex Vojacek


    The plugin is awesome, it works, everything works, contrary to wp that NEVER worked ok for me.

    I only have 2 problems.

    1- version 1.03 completely broke the “bulk” feature, it detects my 700 images and begin de process but the 1.02 ended ok with the list of images proceced while the 1.03 version returns to my website with a “page not found” error (as If I tried to search for an article that is not there).

    2-the compression for jpg does not seem to be optimal, because when I pass the compressed jpg version into “The JPEG Reducer v1.02” (which is the software I was using for windows it still says that there are 2% to be saved.

    Any ideas?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author nosilver4u


    #1: I’m not sure what’s going on. I just made sure it was working on my test install with the latest code, and ran it twice with no issues. It should send you to this address: http://your-wordpress-install/wp-admin/upload.php?page=ewww-image-optimizer-bulk
    Let me know if that is not the case, or if you have any other details that might point out an issue. The bulk optimizer code was modified a bit to make way for the Bulk Optimize ‘action’ in the Media Library drop-down, but I don’t think the url’s should have been affected at all.

    #2: It’s highly likely that the JPEG Reducer is stripping metadata, which is turned off by default on this plugin (because some people might want to keep EXIF info, and comments, and copyright info). You can activate that option via the settings page. Let me know if that closes the gap.

    Thank you for the VERY quick response.

    1- nope, is not working, it always tells me page not found, gonna uninstall the plugin and re-install it to see if it works.

    2- yep, it is stripping metadata, but so are your plugin, that´s the first thing I checked, also, I downloaded the image and checked with fastone image viewer and the image has no metadata so I don´t know what else could it be, just do the test yourself and you will see, download a copy of the JPEG Reducer and try it for yourself, something else is giving a smaller size, strange enough GTMetrix does not report this and displays as the image is ok and compressed so, it must be something else that JPEG reducer is taking out.

    Plugin Author nosilver4u


    #1: let me know, so I can mark this resolved if that works
    #2: thanks for catching that, I was missing the -progressive option. This is now fixed in 1.0.5 (version bumped 2 times, because I forgot some documentation updates)

    I’m soo glad I could help !

    Let me prepare my first morning coffee and try the new version.


    1- Good news, now it’s working perfectly.

    2- still compressing more with JPEG Reducer.

    I give you an example, try and compress this image with your plugin and then with the JPEG Reducer.

    It’s from our E3 Coverage, this pic was reduced with your 1.05 version and it weights 226.786 bytes.

    With JPEG Reducer it weights 188.710 bytes

    Something more is missing, try with progressive and no progressive to see if there is any change, try any other option that may be missing, probably giving a “switch” for progressive on the plugin menu ?

    I am here to further test things out with you, in case you need anything.


    Plugin Author nosilver4u


    The picture you linked appears to be the already optimized one. Can you post the original?

    Yes it is optimized, but the JPEG Reducer optimize it even further, let me put a pic unoptimized.

    Here are a couple not optimized yet.

    Size optimized with JPEG Reducer = 599.734 bytes.

    Size optimized with JPEG Reducer = 55.852 bytes.

    Hope this helps.

    Plugin Author nosilver4u


    What I meant, is that the picture you link appears to be the same size as what you achieved with JPEG Reducer: 188,710 bytes. I’ll take a look at the ones you posted, as they don’t appear to be optimized yet.

    Plugin Author nosilver4u


    When I upload those on my test site that has 1.0.5 installed, I get the same results that you’re seeing with JPEG Reducer: – 55,852 – 599,734

    Perhaps you’re looking at the file size of a cached version? Try optimizing those 2 on your site, and then take a look at the raw files on the server via ftp/sftp or an ssh login (or just clear your cache and view them in the browser again).

    Just to be clear on the changes I made with 1.0.5:
    The plugin now tries to optimize with both the progressive option, and without it, and then saves the one that is smaller (or keeps the original if nothing changes).

    That’s fantastic news! I didn’t knew that.

    You achieved with this plugin what yahoo with WP couldn’t.

    YOu should be commended by this, you and CW creator.

    Gonna try downloading from the ftp, i totally forgot about the browser cache, very sorry about that.

    Plugin Author nosilver4u


    no problems, just make sure you come back to let us know if the issue is resolved.

    Exactly as you said it will be, I was looking at the browser cache copy. I uploaded 5 different images and in all cases they came out exactly the same size as the JPEG Reducer.

    This is definetly working perfectly, congrats man you made my life a lot easier, I’m going to post an article about this plugin on my website for web development.

    Thanks again!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: EWWW Image Optimizer] Two questions about the plugin’ is closed to new replies.