WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: EWWW Image Optimizer] PHP Parse error

[Resolved] [Plugin: EWWW Image Optimizer] PHP Parse error

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author nosilver4u

    @nosilver4u

    sounds like something is corrupted. Try deleting the plugin, and re-installing.

    hmm, seems unlikely, but I’ll give it a shot. I reinstalled 1.0.7 and it worked fine.

    My thought was that I’m not using NGG, so the add_action may have been causing the issue.

    Will try manual upgrade rather than upgrade through wordpress.

    yup, same result. Manually deleted and readded the latest version, same exact result.

    And correction, it’s line 192 that gives the error, which is funny, since that’s a blank line.

    So, interestingly:

    PHP 5.3.10 shows no syntax errors with bulk.php, or the other php files.

    PHP 5.3.8 does.

    Both on Macs… one running 10.7.4, one on 10.6.8 respectively.

    Looking further.

    php -l on any of the php files in 1.0.8 gives me syntax errors…

    Not exactly sure why yet…

    Ah ha, found it.

    On line 28 of bulk.php you used a short open tag — that is to say, only <? where it should be <?php — as without short_open_tag enabled, it’ll give a parse error, and go boom.

    Same thing on line 87 of nextgen-integration.php.

    ewww-image-optimizer.php is fine.

    Plugin Author nosilver4u

    @nosilver4u

    thanks for catching that. I’ll release 1.0.9 with the fix

    Cool, thanks! Already updated, and seems to work.

    Yay habits. =D

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: EWWW Image Optimizer] PHP Parse error’ is closed to new replies.