Support » Plugin: Events Manager » [Plugin: Events Manager] Using #_ATT{} in Default event list format issue

  • Resolved mrtom1981

    (@mrtom1981)


    Hello
    I want to try and use some custom post info within the results I thought i might be able to use the

    #_ATT{}

    within the Default event list format, but it turns out doing this removes the ability to update the custom fields (which is an issue)

    The custom fields display correct, is there a solution to this ?

    If this can not be fixed i was hoping to do a custom loop to receive and perform the retrieve of events using the normal WordPress link but i am having issues ordering them by Future events the default view of the event page set in the plugin.. As if i could sort them i could make my own loop…

    http://wordpress.org/extend/plugins/events-manager/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    Try pasting that in the attributes box in your General EM settings, first panel.

    Hellos
    i already did that and with it there and without the same issue i even stripped all plugins and tried all the default themes still no luck…When i add the it shows up but then stops updating the custom fields… Weird…

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    a bit confused here… could you post a screenshot somewhere of your event form and the problem?

    Btw, re-reading, you can enable both attributes and custom fields together if you need to.

    I have attached a few screen shots of the settings in the plugin..

    http://ScrnSht.com/tunqzd
    http://ScrnSht.com/vcybil

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    I’m still not understanding….

    Ok in a nutshell i have activated and filled in all the blanks to get the custom fields to show on the event list using your
    #_ATT{} like so #_ATT{wpcf-date} and it will show up and that part will work but what it does is freeze the custom fields and will not allow you to update them while the #_ATT{wpcf-date} are listed in the formatting section…

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    sorry if I´m missing the obvious here, but I still don’t get what you mean by

    but what it does is freeze the custom fields and will not allow you to update them while the #_ATT{wpcf-date} are listed in the formatting section

    Ok you I have made a custom field on the events posts, i have made one called wpcf-date when i add the code you describe to show this value within a listing within the events it will show the content fine. But then that custom field can not have its content changed at all when you change and update the content it will revert to the previous content.

    Until the code to add it to the event system is removed…

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    i think i get it now. a screenshot of your admin area where the values aren´t changing may help, but that´s not normal so I’d suggest trying to save the values with other plugins disabled to see if that helps.

    A screen shot would not show much really, but here is a link to one…http://ScrnSht.com/yjtcrh

    I have tried it on a fresh install of wordpress with no content and default theme and no other plugins except Event Manager still the same issue..

    are you using Plugin Types – Complete Solution for Custom Fields and Types ?

    you can go to Types > Custom Fields > Choose one and Edit > Where to display this group > Post Types: click edit and check Events/Recurring Events; then if add/edit events a metabox will show that will let you add/update custom fields values that you created on types plugin.

    Hi aglonwl i tried this with and without types plugin still the same issue i am afraid by adding the custom field to the formatting section it renders the custom fields whether they are the basic wordpress version or any fancy plugin version broken and not allowing the content to be updated..

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    i’d say this looks like a plugin conflict. have you tried disabling custom post fields and just enabling our attrbibutes in the Events > settings > General > General Options panel?

    I have installed Events plugin on a fresh install with no other plugins installed and still the same issue and used it with the default themes..

    The attributes do not allow for visual editor input to allow for formatting content with HTML when the client doesn’t know it..

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    But you’re using the usual WP custom fields, if you use our attributes meta box they’ll only be able to enter those values – http://wp-events-plugin.com/documentation/event-attributes/

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Events Manager] Using #_ATT{} in Default event list format issue’ is closed to new replies.