Support » Plugins and Hacks » [Plugin: Events Manager] Syntax Error

[Plugin: Events Manager] Syntax Error

  • I’m getting the following error when trying to activate the plugin:

    Parse error: syntax error, unexpected $end in C:\XAMPP\xampplite\htdocs\wordpress\wp-content\plugins\events-manager\dbem_events.php on line 2214

    I’m using wordpress 2.8.4 and I have no other plugins installed or activated at this time. Also, I’m running the site on my hard drive using XAMPP for the time being until I buy a site.

    Any ideas on what I can do?? I’m a bigtime noob.


Viewing 9 replies - 1 through 9 (of 9 total)
  • i have the same problem with this plugin – seems to be incompatible with v2.8.4

    I have the same problem with this plugin.



    This is a known issue and resolved on the forum of this plugin. But if you can’t or don’t want to fix it yourself: I’ve created a new archive containing all current fixes here .

    2 ways of installing:
    – uninstall your old version and install this one
    – just copy over the files from this archive over your old files. But then you need to create an extra column in the database yourself: in the table dbem_recurrence, add a column called “event_category_id” with the same settings as the column “event_category_id” in the dbem_events table.


    Hi Franky, I REALLY want to use this plugin, looks great. But, even after getting the updated archive of fixes, I still cannot activate. I get the error below:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected $end in 
    \wp-content\plugins\events-manager\dbem_events.php on line 2233

    Apologies, found an answer here: http://davidebenini.it/events-manager-forum/topic.php?id=300

    I enabled short open tags on my Win XP xampplite and now the plugin is activated. Hopefully that is last hitch and things go smoothly now. I’m very excited about the plugin. -Zach

    In the last message left by liedekef he linked to a file that had some fixes for the installation issue. Zhannes was getting the same error I was getting. But instead of enabling short tags in PHP I just went on and corrected the short tags in the dbem_events.php file. After that the plugin installed without any errors.

    The short tags that need to be corrected are on the following lines:

    • 1364
    • 1387 (2 short tags are on this line)
    • 1388
    • 1390
    • 1587

    Hopefully in the next release there will be consistency used when declaring php blocks.


    We will definitely run a search and replace to make sure there are no more offending short tags.

    Thanks for pointing out the offending lines, those will be taken care of in the next release.


    Ok, Im not seeing those. I’ve got the page open, and my version doesn’t have those errors at all on those lines. Furthermore I’ve got short tags turned on…and still Im hitting the dreaded error of no activation. Sigh, no joy for me.


    @ All.

    I was able to turn on SHORT CODES and all of those issues went away. My issue was that my php.ini file had moved to an odd place instead of the /etc folder where its supposed to be. I have to set up a symbolic link to the new file from the old location…oy. Took forever to actually figure out what was going on.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Events Manager] Syntax Error’ is closed to new replies.