Support » Plugin: Events Manager » [Plugin: Events Manager] Issue with permalinks

  • Hi, I’m trying to use this plugin but I’m having trouble with permalinks. They work fine when set at default but anything else I get a 404 when trying to view any events. I have tried it with the Twenty Eleven theme to make sure it was not an issue with the theme I was using but I am still having the issue. Any suggestions? This was not an upgrade from version 4. I installed version 5.1.7 and got these issues.

    Thanks!

    http://wordpress.org/extend/plugins/events-manager/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    hi, what type of server do you use, and how do your permalinks look like (e.g. give me an example page url)?

    The server is apache and the permalinks are set for Month and Name. Here is an example when trying to view an event: http://www.numeropublishing.com/events/orality-in-james-joyce-conference/

    Thanks for the help!

    Did you try to change your wp permalinks at (your current permalink) wp settings > permalinks > default to Day and name permalink (save)? then revert back to your default permalink

    @agelonwl I have tried every choice I have in terms of permalinks and none work except for default. I do see the events page when using this url structure http://www.numeropublishing.com/events/ but when I click on the event it goes to 404 no matter what I have permalinks set to.

    Hi

    +1.
    For me it seems to be worse for recurring events; with these adding custom attributes or any sort of customisation breaks the links…

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    @graphical_force it looks to me like you don’t even have an .htaccess file to handle the mod_rewrites. Otherwise it’d show you a 404 page via wordpress.

    @marcus This is what I have for an .htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Still no matter what I have permalinks set to, I get a 404 only when viewing events, nothing else.

    Hi,

    For wp permalinks – http://codex.wordpress.org/Using_Permalinks

    Also, I found this events list link in your site and clicking single events seems to work – http://www.numeropublishing.com/?page_id=2522

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    that’s cuz he disabled permlainks now.

    do other bad URLs work? normally if htaccess is working, you’ll be shown a wp 404 page.

    otherwise, have you tried disabling your other plugins and/or reverting to the 20 11 theme? You’ll need to resave permalinks when doing this.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Events Manager] Issue with permalinks’ is closed to new replies.