WordPress.org

Forums

Events Manager
[resolved] Installation Error (27 posts)

  1. gobbleoff
    Member
    Posted 4 years ago #

    Hi all, I just installed WP and Events Manager, and upon installation of EM, I get the following at the header of my site:

    Warning: session_start() [function.session-start]: open(/tmp/sess_9d42a748d912cdfcea073f38c0e1c1fe, O_RDWR) failed: Read-only file system (30) in /home/carclube/public_html/wordpress/wp-content/plugins/events-manager/classes/em-notices.php on line 11
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/carclube/public_html/wordpress/wp-content/plugins/events-manager/classes/em-notices.php:11) in /home/carclube/public_html/wordpress/wp-content/plugins/events-manager/classes/em-notices.php on line 11
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/carclube/public_html/wordpress/wp-content/plugins/events-manager/classes/em-notices.php:11) in /home/carclube/public_html/wordpress/wp-content/plugins/wordpress-mobile-pack/plugins/wpmp_switcher/wpmp_switcher.php on line 506

    any ideas on where to start looking?

    http://wordpress.org/extend/plugins/events-manager/

  2. gobbleoff
    Member
    Posted 4 years ago #

    and I get this at the footer of the site:

    Warning: Unknown: open(/tmp/sess_9d42a748d912cdfcea073f38c0e1c1fe, O_RDWR) failed: Read-only file system (30) in Unknown on line 0
    
    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0
  3. agelonwl
    Member
    Posted 4 years ago #

    hi,

    you can try turning off your PHP display_error...does your installation fails to work at all and is it the latest update?

  4. gobbleoff
    Member
    Posted 4 years ago #

    I get absolutely zero errors with the install.

    ive put this in wp-config.php

    error_reporting(0);
    @ini_set(‘display_errors’, 0);

    and get the same errors on the website.

  5. agelonwl
    Member
    Posted 4 years ago #

    its should be turn off at your server (PHP thru ini file) But did you try disabling wordpress-mobile-pack plugin (see it at error outpu

    And does your EM is not working at all or just showing this warning?

  6. gobbleoff
    Member
    Posted 4 years ago #

    mobile pack is deactivated.

    it looks like it works on the page, but when i drag the widget to the sidebar, i get php errors just above the Title textbox

    Warning: session_start() [function.session-start]: open(/tmp/sess_0e195be0969e1b3a6a89dbef04536289, O_RDWR) failed: Read-only file system (30) in /home/carclube/public_html/wordpress/wp-content/plugins/events-manager/classes/em-notices.php on line 11
    
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/carclube/public_html/wordpress/wp-content/plugins/events-manager/classes/em-notices.php:11) in /home/carclube/public_html/wordpress/wp-content/plugins/events-manager/classes/em-notices.php on line 11
  7. agelonwl
    Member
    Posted 4 years ago #

    did you try turning off the php display error?

  8. gobbleoff
    Member
    Posted 4 years ago #

    I'm on shared hosting so can't change php.ini

    I've added the above lines into wp-config.php to hopefully turn off the errors, but regardless if its in there or not, the errors display.

  9. agelonwl
    Member
    Posted 4 years ago #

    if incase it just showing warning and everything works perfectly try this @ wp-config.php

    @ini_set('log_errors','On');
    @ini_set('display_errors','Off');
  10. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 4 years ago #

    it's probably that your theme or another plugin is outputing whitespace before EM has a chance to start sessions

    either that or you have some issue with sessions in your php setup

  11. gobbleoff
    Member
    Posted 4 years ago #

    thanks guys. it wasnt anything on the software side, at the same time as this, i put in a support ticket, and it was fixed on the (shared) server side.

    am going through and testing wp-events now before putting it into review.

  12. Frankie Jarrett
    Member
    Posted 3 years ago #

    @gobbleoff is your hosting through GoDaddy? I know someone having the exact same issue and we're trying to get to the bottom of it.

    //Frankie

  13. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    looking at that error again, i just realized that this would have been caused most probably by bad permissions in your web server settings or the temporary folder for sessions.

  14. inTOWN
    Member
    Posted 3 years ago #

    Having the same problem and also not able to change php.ini

  15. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    inTOWN:
    did you contact your host about it?

  16. inTOWN
    Member
    Posted 3 years ago #

    My host thinks it might have to do with how I set up my test user accounts. When not having a domein name I use the 100.100.100.100/~testuser option, which according to him is not the right solution.

    So, I have to set it up differently,
    For now I just commented out line 11 at em-notices.php which also does the trick...

  17. inTOWN
    Member
    Posted 3 years ago #

    My host thinks it might have to do with how I set up my test user accounts. When not having a domein name I use the 100.100.100.100/~testuser option, which according to him is not the right solution.

    So, I have to set it up differently,
    For now I just commented out line 11 at em-notices.php which also does the trick...

  18. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    you might have issues with regards to success/error messages not showing by doing that, but aside from that the plugin should work.

  19. redturbo917
    Member
    Posted 3 years ago #

    Greetings all. I am having similar problems with Events Manageron a godaddy server.

    Frankie Jarrett? Did you ever sort out your errors with Godaddy? they moved our site to a new server and they changed our permissions and we lost use of event manager.

    I will post any updates here for us.

    Cheers!

    Mike

  20. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    If they changed permissions on your server, you should try to get them to set them correctly.

  21. greigner
    Member
    Posted 3 years ago #

    I ran into this issue when moving a WordPress site from one server to another.

    - I was using GoDaddy shared hosting
    - I was using Events Manager plug-in successfully before the move
    - The day the move to a new server was completed, I received the errors mentioned above; in addition, all my sites pages were missing, and I couldn't even log in to the back-end to make changes (using FireFox)

    *****Resolution (i.e. for my specific situation) *****

    - To immediately solve the problem from a visual standpoint, log in to your WordPress site using Chrome or another browser (you'll have to test). DEACTIVATE the Events Manager plug-in. Once that is done, the site should return to it's normal self (visually)
    - Via an FTP client, check the root of your hosting for a folder called 'tmp'. If it is missing, create it. If it is there, open all permissions for that folder.
    - If the above fails to work, call your hosting company. Provide them a link to this forum, and if necessary, reactivate the plug-in so they can see the error message; they can check additional permissions and folders if needed and help get you back in action.

    Hope that helps!

  22. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    thanks for sharing your solution

  23. greigner
    Member
    Posted 3 years ago #

    My pleasure.

  24. sjaved
    Member
    Posted 3 years ago #

    If you put error_reporting(0); in wp-config file it will permanently off the error notices throughout the sit. If you are developer this is not good.

    You can simply edit the 'em-notices.php' file and put erro_reporting(0); on very top of the file.

    Thanks.

  25. Surf7.net
    Member
    Posted 3 years ago #

    create an empty php.ini file and put in this line...

    safe_mode = Off

    upload it to your public_html folder. after that, add this line in your .htaccess file...

    suPHP_ConfigPath /PATH/TO/public_html

    of course edit the above line to match your path to your public_html folder.

    It works for me.

  26. leivreed
    Member
    Posted 3 years ago #

    Thanks so much for this guys! The internet is amazing!:D

  27. Frankie Jarrett
    Member
    Posted 3 years ago #

    The internet is amazing!:D

    quote of the year

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Events Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic