Support » Plugin: Events Manager » [Plugin: Events Manager] Downgrade

  • Resolved thinkmedia

    (@thinkmedia)


    I upgraded to 5.2.2.1 and got this message now.

    Events Manager upgrade not complete, please upgrade to the version 4.300 or higher first from here before upgrading to this version.

    How do I downgrade without losing all existing settings?

    Do I have to remove the plugin, then install the old one, then upgrade to 5.2.2.1 ??

    Thanks

    http://wordpress.org/extend/plugins/events-manager/

Viewing 15 replies - 1 through 15 (of 15 total)
  • can I know what version you are using before upgrading? this post might help you if you are using version4 – http://wp-events-plugin.com/updating-to-v5/

    Plugin Author Marcus

    (@netweblogic)

    You shouldn’t lose any settings, what version did you upgrade from?

    I just took over a site and there were multiple plugins needing updates.
    I didn’t not notice which version of Event Manager it was.

    So should I uninstall the plugin and then install the latest version?
    Will the data be lost if I do that?

    Thanks!!!!

    OK, while waiting I have rebuilt the site in an dev location.
    http://suzieqbbb.com/?page_id=176
    I deleted the plugin via FTP.
    Then added the version 4.30
    Then updated to 5.2.2.1

    All the records are still there.
    The plugin doesn’t throw an error

    BUT —– the page doesn’t display the events at all.

    Any help you can provide would be greatly appreciated.

    Thanks!!

    Plugin Author Marcus

    (@netweblogic)

    Have you assigned the right Events page under Settings > Pages > Events List/Archives

    Yes, I checked that.
    It’s assigned to the proper page.

    Plugin Author Marcus

    (@netweblogic)

    what about when you use a sortcode e.g. [events_list]?

    otherwise, try re-saving an event to see if it turns up.

    I’ve resaved the page and resaved multiple events

    I’ll try using a shortcode “in” the page

    Shortcode works … but that doesn’t make sense and isn’t long-term solution.

    If I assign a page, it gives me a 404 error
    http://mitchpopilchak.com/demo/bbb/our-classes/schedule/

    Do you want access to admin?

    Plugin Author Marcus

    (@netweblogic)

    i only do that for pro users, unless it’s a serious bug. I’m pretty sure you have a setup issue or a plugin/theme conflict.

    I never asked you, but did you try this without other plugins running and/or using the twentyeleven theme?

    Oh, ok.

    Nothing changed except trying to upgrade this plugin.
    Quite simple.
    It appears to be the upgrade from a lower version to v5.2.2.1 and I am guessing leap-frogging version 4 is the issue.

    It’s kind of frustrating. Even though I have it running now with the shortcode, the normal way isn’t working. Which means I will have to delete the plugin, clear the database, and reinstall and then one at a time add the events back in if the plugin is going to work properly again.

    ggrrrrrr

    Thanks for all the suggestions and input though

    Cheers,

    Mitch

    Plugin Author Marcus

    (@netweblogic)

    I’d still try the suggestion.

    I doubt re-installing is necessary to fix this. One thing you could try is resetting it (i.e. clear your settings only)

    Nope, that didn’t work either

    I’ve deactivated all plugins and reset the settings.
    Still throwing a 404 error page.

    Plugin Author Marcus

    (@netweblogic)

    Not sure this’ll help, but try running this SQL query to clean the events/locations from the posts table and trigger a re-install, but this should still keep your old information and re-migrate them.

    DELETE FROM wp_postmeta WHERE post_id IN (SELECT ID FROM wp_posts WHERE post_type IN ('event','location','event-recurring'));
    DELETE  FROM wp_posts WHERE post_type IN ('event','location','event-recurring');
    UPDATE wp_em_events SET post_id=NULL;
    UPDATE wp_em_locations SET post_id=NULL;
    UPDATE wp_options SET option_value=4.9 WHERE option_name = 'dbem_version';

    Thanks for the idea but nope.
    Did not work.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Events Manager] Downgrade’ is closed to new replies.