Support » Plugins and Hacks » [Plugin: Events Manager] Date Picker not working – conflict with Easy Post Types?

[Plugin: Events Manager] Date Picker not working – conflict with Easy Post Types?

  • Hi there – the date picker isn’t displaying for me when adding a new event. I can add the date in manually, but it gives an error when I submit the event: “Missing fields: event_start_date”.

    It seems to be a conflict another plugin – Easy Post Types. When I disable this plugin, the date picker works fine.

    I really need both plugins, but not being a programmer, I’ve got no idea how to fix the conflict. If anyone can help, I’d really appreciate it.

    If there’s any way to allow Events Manager to accept a manually entered in date, that would be all really need.


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Marcus


    not without some hacking

    the datepicker JS loads only on EM pages, so the conflict is most probably on the Easy Post Types plugin. I am guessing that they load some JS on every admin page which is not good practice if not necessary. you should let them know this.

    Thanks Marcus.

    I ended up doing some digging around Easy Post Types, and found it was using the same datepicker js for its custom date fields. As I’m not using date fields for any of my custom post types, I just disabled it.

    The date picker is working fine in EM now 🙂

    Plugin Author Marcus


    thought so, glad you sorted it out.

    I’ve tagged the conflicting plugin on this topic too in case the developer wants to sort this out (see earlier comment for details on how)

    I got my Easy Post Types datepicker working by changing the plugins/easy-post-types/classes/custom-datefield/custom-datefield.php file to have a call to 1.7 instead of 1.8 (it is almost the last line):

    wp_enqueue_style('custom-datefield-style', 'http://ajax.googleapis.com/ajax/libs/jqueryui/1.7/themes/base/jquery-ui.css');

    I was trying to find out what had caused the Date Picker field in Easy Post Types stop working and came across this thread, changing it to 1.7 worked for me too.
    I have emailed the developers of Easy Post Types telling them about the problem with the Google-hosted CSS file. Kind of makes you wary of using any kind of CDN hosted CSS or JS when something like this happen!


    I just installed events manager and I am experiencing the same problem: date picker doesn’t work and doesn’t show. The difference is I don’t have any Easy Post Types plugin, and there are no plugins in my list that I am aware of, that use any date picker.

    Any idea what happens?



    Well, for some reasons now it just works. Might have been a cache problem… Sorry for disturbing!

    what is the correct way to enter the date and what is the date picker i have never seen it?
    i keep getting this message no matter how I try to enter the date and I don’t have Easy Post Types either.

    Missing fields: event_start_date.

    Since the event is repeated, you must specify an event date.

    Dates must have correct formatting. Please use the date
    picker provided.

    good news is for the first time today I have finally seen the recurrence column on the right. but when that started showing up dates can’t be entered now.



    Plugin Author Marcus


    you either have a problem with your theme or another plugin that’s causing javascript errors. if you know how to view the javascript console I’m sure you’ll see errors there (i bet you see two titles, one for recurrence dates and another for normal ones?)

    if you tried disabling other plugins and/or switching to twentyten theme it’d probably start working.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Events Manager] Date Picker not working – conflict with Easy Post Types?’ is closed to new replies.