WordPress.org

Forums

Events Manager
[resolved] Can't create new events suddenly - permission problem? (9 posts)

  1. eddr
    Member
    Posted 2 years ago #

    Hi

    I've installed "Event manager" which seems perfect for my needs and customization desires.
    Now, everything worked fine even after I did several changes to the formatting through the plugins interface.

    I left it and continued working on other things. When I got back to this, I found out that I can't create new events and some more options are missing from the admin panel.

    That's what I did to check it:
    1. Tried to use a link to edit some old event post I has and got the "cheatin uh?" message.
    Permissions?

    2. restarted the plugin through the admin panel => can create new event, but when I do some changes to the settings and saves it, the new event option disappears again.

    3. Uninstalled, deleted and installed again the latest version - same problem.

    4. THEME - changed to the "twenty eleven" theme and another one - still the same.

    5. Other plugins - Have only 8 basic plugins, but I tried to deactivate them all and then restarted the "events manager" plugin - same.

    What could it be?

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 2 years ago #

    did you check user capabilities at settings > general > user capabilities ? also, what are the options that is missing? do you have a sample screenshots?

  3. eddr
    Member
    Posted 2 years ago #

    Hi

    1. Yes.
    2. The admin panel
    http://imgur.com/93USv
    The plugins permissions
    http://imgur.com/yw4Sz

    Thanks!

  4. eddr
    Member
    Posted 2 years ago #

    ?

  5. eddr
    Member
    Posted 2 years ago #

    please advise.
    Noone else gets this?

    Which functions is called when the submit button on the options page is clicked?

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    try deactivating your other plugins, uninstall or reset events manager under settings > Admin tools

    my guess is a permissions problem caused by another plugin, doing the above should reset EMs permissions again.

  7. eddr
    Member
    Posted 2 years ago #

    I have found the problem.
    1. One I've described in another thread regarding wrong array definition - "cap_docs" or something like that: It is an array of arrays and each sub-array has an extra "," after the last item.

    2. There is a problem in the Hebrew translation. Using "%S" instead "%s" and that causes problems. One big problem is that the capabilities in the plugin's settings sections are not shown and therefore saves as they were unchecked checkboxes - making even the administrator permissionless.

  8. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    someone sent me an updated po file which I think fixes this, so will update the next stable release.

  9. akseer
    Member
    Posted 1 year ago #

    Thank You Marcus, I have reset the Event Manager plugin , Issue is resolved.Now i have permission to create new event.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Events Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic