Support » Plugin: Events Manager » [Plugin: Events Manager] Address displayed twice for existing events on [event_form]

  • Resolved Daedalon

    (@daedalon)


    The address for existing events is displayed twice by the autocomplete dropdown. The HTML output is:

    <a class="ui-corner-all" tabindex="-1">Place, Address, City<br><span style="font-size: 11px;"><em>Address, City</em></span></a>

    Either one of the “Address, City” strings should be removed, and I’d suggest the latter; removing the whole <span> element and its contents.

    Steps:

    1. Create a place that has an address and a city.
    2. On a page that contains [event_form], enter the first two letters of the name of the place you added in the Location Name field.
    3. In the dropdown suggestions, you’ll see the name of the place with its address and city written twice.

    http://wordpress.org/extend/plugins/events-manager/

Viewing 14 replies - 1 through 14 (of 14 total)
  • do you also have a sample link or screenshot instead?

    hi,

    sorry but everything is working fine on my test site; Is this when you are logged-in or out? also, can you try it again with other plugins disabled or temporarily reverting back to default theme to narrow down the problem?

    The [event_form] is only accessible for logged-in users on our site. I’ll get back to this after testing the issue on a development environment with plugins turned off and with the default theme.

    After setting up a replica site, switching to the 2011 theme and disabling all plugins except Events Manager, the issue is still there.

    What’s the next step in our bug hunt?

    Plugin Author Marcus

    (@netweblogic)

    you must be missing something here. it definitely works on a vanilla install so you must have something still activated.

    Tried today again with the default .htaccess file and with the wp-admin/.htaccess file removed, to no effect. What else could there be?

    Marking this topic as not resolved.

    Plugin Author Marcus

    (@netweblogic)

    that wouldn’t make a difference. you must have something else installed there messing it up.

    alternateively try it on a test server or similar. it definitely works – http://demo.wp-events-plugin.com/submit-your-event

    Plugin Author Marcus

    (@netweblogic)

    or re-install the plugin

    The address gets displayed the exact same way to me on the demo site on both Pale Moon (optimized Firefox) newest and Internet Explorer 8. Screenshot: http://i.imgur.com/uU7Fr.png

    It’s most curious if you’re not seeing the same thing, the address being displayed twice: first on the first line in a big, bolded font, then on the second line on a smaller, italic font.

    Plugin Author Marcus

    (@netweblogic)

    ok i see what you mean now. I’ll fix that so the location name only is on top, then the address

    Great!

    I wouldn’t say no to an option to modify the formatting, though. I’d immediately set the address’s font-style to normal instead of italic.

    In other words, one more textbox under Formats/Layouts > Events, with roughly the following as the default value:

    <span style="font-size:16px;font-weight:bold;">#_LOCATIONNAME</span><br />
    <span style="font-size:11px;font-style:italic;">#_LOCATIONADDRESS, #_LOCATIONTOWN</span>

    Writing this in the same thread as it might be something you’d like to change at the same go for 5.1.9.2.

    Plugin Author Marcus

    (@netweblogic)

    I changed it when i wrote the above, have a look at the one in the latest dev version.

    Now it works otherwise well, except that occasionally either the name of the location or the address is broken into two lines on my site, and neither is the name bolded or the address italicized. The issues appeared on our site immediately after upgrading from 5.1.8.5 to 5.2.1, but do not seem to occur on the demo site.

    Issue 1

    Based on the phrase typed in the location field autocomplete lists only one location in particular as supposed. The ul
    element created by the autocomplete script has a width of 159px. The location is displayed on the screen as:

    Title
    Streer address,
    Town

    The browser breaks the address information on two lines based on the width of the ul element.

    Issue 2

    After typing a different (and shorter) phrase in the location field, the autocomplete lists 10 locations. The ul element created by the autocomplete script has a width of 234px. Some of the locations are displayed as they’re supposed to (except that the title is not bolded), but some are displayed like this:

    Long title with many
    words
    Streer address, Town

    The long titles are broken into two lines based on the width of the ul element.

    Attempts at solving

    Disabling the Search Autocomplete plugin made the main issue of width disappear. A look into the HTML of the page revealed that the difference is that now the ul element is one px wider in both cases, 160px and 235px respectively. As this issue did not appear with 5.1.8.5, something has been changed for 5.2.1 that broke this.

    Disabling all the other plugins on the test site except EM and WP Super Cache had no effect.

    Reverting to the 2011 theme returned the bolded titles and italicized addresses (the latter of which we do not prefer). The update from 5.1.8.5 to 5.2.1 seems to have only broken them with Elbee Elgee theme.

    Hope you’ll find a fix to these two compatibility issues and make the formatting an excellent customizable setting like everything else in Events Manager.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Events Manager] Address displayed twice for existing events on [event_form]’ is closed to new replies.