WordPress.org

Support

Support » Plugins and Hacks » Events Manager » [Resolved] [Plugin: Events Manager] #_EVENTIMAGE{x,y} doesn't work

[Resolved] [Plugin: Events Manager] #_EVENTIMAGE{x,y} doesn't work

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author Marcus

    @netweblogic

    does it show the placeholder or is it a blank image? If the latter, make sure you have the right permissions in your uploads folder (e.g. like with wordpress)

    It’s a place holder. You can see it here:

    http://the-london.sarumbear.com/wp/events

    Default event list format is as below:

    <div style=float:right;margin-left:20px;">#_EVENTIMAGE{100,100}</div>
    <strong>#_EVENTLINK</strong><br>
    #_EVENTDATES - #_12HSTARTTIME<br><br>
    #_EVENTNOTES
    <div style="clear:both;margin-bottom:20px"></div>

    Hi,

    Using your posted format, it works for me without any problem. Please try to right click the image in your website and you will see a PHP warning which maybe a permission problem.

    Strange. I see the server error as well but I cannot understand what can be wrong at the server.

    I have changed #_EVENTIMAGE{100,100} to #_EVENTIMAGE on the above code and it works OK. If it is a server error how come the none-sized code works?

    http://the-london.sarumbear.com/wp/events

    Plugin Author Marcus

    @netweblogic

    Probably a permissions error in your folders, check that you have the correct permissions in your wp-content/uploads

    I have checked the server and have it checked by my host but neither of us can find anything wrong. As the images are accessible directly the issue seems to be at the plugin level.

    Here is the direct URL of the image, which displays fine:

    http://the-london.sarumbear.com/wp/wp-content/uploads/2012/01/dj-e1325705249544.jpg

    and here is the link your plugin generates, which fails:

    http://the-london.sarumbear.com/wp/wp-content/plugins/events-manager/includes/thumbnails/timthumb.php?src=http://the-london.sarumbear.com/wp/wp-content/uploads/2012/01/bingo-logo1-650-e1325706856998.jpg&h=100&w=100

    May I ask you to please double check?

    Thank you

    Riz

    can you check this file/image
    Warning: touch(): Utime failed: Permission denied in /usr/local/pem/vhosts/107487/webspace/siteapps/19836/htdocs/wp-content/plugins/events-manager/includes/thumbnails/timthumb.php
    and
    Warning: file_exists(): open_basedir restriction in effect. File(/usr/local/pem/vhosts/107487/webspace/httpdocs/the-london/wp/wp-content/uploads/2012/01/bingo-logo1-650-e1325706856998.jpg) is not within the allowed path(s)

    I gave 777 permissions for the below file, but there’s no change.

    /usr/local/pem/vhosts/107487/webspace/siteapps/19836/htdocs/wp-content/plugins/events-manager/includes/thumbnails/timthumb.php

    The below link displays the image correctly, hence the image exists and served.

    http://the-london.sarumbear.com/wp/wp-content/uploads/2012/01/bingo-logo1-650-e1325706856998.jpg

    I don’t know what else to do. I give up. I will resize the images and use #_EVENTIMAGE instead, which works fine.

    Plugin Author Marcus

    @netweblogic

    You need to sort those openbasedir issues too (the error angelo mentioned) which is a server setting and you need to set permissions to your wp-content/uploads folder, it now stores thumbnails there.

    HI, i have the same problem.
    I cannot display #_EVENTIMAGE{150,150}.

    Link Thumb

    The server said:

    Failed to load resource: the server responded with a status of 400 (Bad Request)

    and the error is:

    A TimThumb error has occured

    The following error(s) occured:
    Could not find the internal image you specified.

    Query String : src=http://reportereporter.altervista.org/giornale/wp-content/uploads/2012/01/rose-2.jpg&h=150&w=150
    TimThumb version : 2.8

    I gave 777 permissions for all ad the file is in the directory!

    Thank you in advance!

    Plugin Author Marcus

    @netweblogic

    check your php logs, looks like php is having issues accessing your image for some reason.

    I Done it!
    I said my php logs was:

    Failed to load resource: the server responded with a status of 400 (Bad Request)

    Plugin Author Marcus

    @netweblogic

    your php logs would give more information than this, you usually access these via your hosting control panel or directly via FTP to your server.

    Hi,
    I face the same issue. Using #_EVENTIMAGE works properly. But using #_EVENTIMAGE{150,150} calls an image, which doesn’t exist: e. g.

    <img src=”http://www.salsa-trips.com/wp-content/plugins/events-manager/includes/thumbnails/timthumb.php?src=http://www.salsa-trips.com/files/2011/02/Switzerland-Zurich-Salsafestival.jpg&h=150&w=150″ alt=”Salsafestival Switzerland”>

    notation of my images looks like Switzerland-Zurich-Salsafestival-150×150.jpg

    => without &h=60&w=120

    Is it possible to scale the image (dynamically) instead? Thank you.

    http://www.salsa-trips.com/eventz

    Plugin Author Marcus

    @netweblogic

    you could use IMAGEURL instead and make an image tag with width and height.

    however, your problem will be that you have a folder permission error of some sort for sure.

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Resolved] [Plugin: Events Manager] #_EVENTIMAGE{x,y} doesn't work’ is closed to new replies.
Skip to toolbar