Support » Plugins and Hacks » Events » [Plugin: Events] Line Breaks Have Disappeared

[Plugin: Events] Line Breaks Have Disappeared

  • What is your domainname: http://www.shellypalmer.com
    Which version of the plugin do you have:
    Which wordpress do you use: 3.3.1
    What did you try to solve this issue: Entering the breaks manually solves the issue, but is impractical as all Events have lost their formatting
    Is your WordPress a multisite/networked installation? No
    Describe your problem short, to the point and without a long story around it: Sometime in the past week, all events on our site have lost their line breaks. So what used to read…


    …now reads….

    “Photo Title Location”

    Like I said above, going into the html editor and manually adding the breaks solves the issue, but there are hundreds of old events that have lost their formatting so another resolution would be helpful.


Viewing 7 replies - 1 through 7 (of 7 total)
  • Linebreaks don’t just up and dissapear. Something must have changed.
    New wp, added a plugin that kills a filter… Stuff like that.

    Hi had the same problem and still haven’t found how to fix.. Please let me know if you have.


    I’ve been experiencing the same issue.

    Any paragraphs or line breaks inserted in an event seem to be stripped out when displayed as part of the %event% variable.

    This is on WP3.4.1 and Events

    It’s also happening on my own domain with WP3.3.2 and Events installed – I just added the plugin to test it.

    Otherwise, everything seems to be functioning as it should!


    Odd, nothing changed for outputting events in the latest update that I remember.
    Perhaps I’ll fix it sometime. Kinda busy with AdRotate right now.

    Just thought I’d mention that I’m having the same problem.


    I managed to fix this (via a slight hack, admittedly).

    Open the wp-events-functions.php file in the plugin. go to around line 333 where it says:

    $output .= stripslashes(html_entity_decode($footer));

    and then change it to read:

    $output .= stripslashes(html_entity_decode($footer));
    $output = str_replace("\n", "", $output);

    (i.e. you add the second line in). And voila.



    Adding that extra line did not work for me. I am using WP 3.5.1 and Version of Events plugin. Any other ideas on getting this to work?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Events] Line Breaks Have Disappeared’ is closed to new replies.