Support » Plugins and Hacks » [Plugin: Events Calendar] HTML showing up in popup!

[Plugin: Events Calendar] HTML showing up in popup!

  • hi,

    thank you for this – just in time – had complaints about the old format with the ‘go’ button and the year not as a drop down – this solves both issues… but….

    now on hover (the popup is slow) and it shows HTML tags:
    <Title> etc…. how do i kill that ‘feature’ …. and just as important – how do I reset the date – I am in Hong Kong and it is the 28th here at 12:40am – but the calendar is hilighting the 27th – if it can’t be corrected in this version – how do i turn the new date ‘feature’ off…. of course fixing it to a +8 GMT would be preferable!

    thank you!!!


Viewing 15 replies - 1 through 15 (of 15 total)
  • …also seem to have lost the ability to move to the next month….. in the sidebar…

    … when i enter a new event into the calendar – the popup date selection calendar is showing up correctly as the 28th – it is picking the date up from the WP settings – it is jut the sidebar that is not.

    1. Still showing <title><strong- even word press won’t let me write <strong without changing it!> need noedit tags for this post!. help isn’t anyone else seeing this?
    2. found this for the timezone – but am afraid to touch the scripting – and not even sure which one it goes into. tried adding this O0200 and O +0200: to ‘options’ with no effect: what do I do with the below?

    string date ( string $format [, int $timestamp ] )
    O Difference to Greenwich time (GMT) in hours Example: +0200

    These are all related to your theme.

    To make sure, go to Luke’s website and cursor over a date with an event. If it shows up ok, then it is related to your theme.

    You can also get the Theme Test Drive plugin and choose a different theme.
    If everything is ok in the new theme, then the problem is with your current theme.

    As for the correct date and time, you should be setting that in WordPress. That is dependent on your host.

    I have completely customised this theme – and it just went live – i do not see HTML on Luke’s site – but I have no clue what to change in this theme – the client would kill me if I messed with it now!

    Do you know what in the theme could be causing it?

    Date and time is correct in WordPress on this site just not on the sidebar calendar – it has a mind of it’s own – and really needs to allow that setting in its options….

    You are probably right about the sidebar taking it’s ‘time’ from the server – which is why it didn’t change here at mid-night – the host is in California.
    But the events management date selection is taking it’s ‘time’ from the site and shows correctly – shouldn’t this pass on to it’s sidebar widget?

    @scoophk, I just changed themes and didn’t look into why it wasn’t working on the theme I had. (I had set up this theme for testing so it didn’t matter.)

    I don’t understand what you mean when you say the “time” isn’t correct on the sidebar widget. The time should be whatever you type in.

    On the “Options” page for Event Calendar, change the “Widget Calendar Times” to “h:i:s a”. You can put in the same thing for large calendar. Just make sure you put a “colon” inbetween and not a “dash”. The “h” allows for a leading zero in the hour. Enter your time for the event as

    sorry not to have been clear – by time (the reason it was in quotes) i meant the 12-15 hour difference between my host server and hong kong.

    on the manage tab in the WP 2.5 site the date is correct – on the sidebar it is 15 hours behind.

    I am wondering if that could be theme related as well…. altho it is off for me on two sites with two different themes both running WP 2.5 one with EventCal 6.0.4 and one with 5.8.2

    Have deleted the least important event so that the other would show up – til this is resolved.

    Am wondering if the sidebar.php or or the .css is the controlling factor here. As it is the smaller of the two – wondering if you could post the code from the working sidebar theme here for me to compare to my non working one – or if you can spot the differences in the two that you tested comparing the sidebars and the style.css – and see if you can see why one works and the other doesn’t.

    @scoophk, have you checked on the “settings” page under “General Settings”? On that page you should see “Timezone” where you set the difference in time. You should also see “Date Format” and “Time Format”.
    These should show the correct date and time for your location. If they don’t, you need to adjust the timezone.

    I don’t know if your problem is theme related or not. You said that it had been customized, so there is no way for me to tell. I’m going to look at a theme that doesn’t work with the plugin and one which does to see if I spot the problem. I’ll let you know if I find anything.

    Thanks – general setting is set correctly anything in the site body displays the correct time zone – only the sidebar widget seems to get its time zone from the host server.

    There has been problems with this when not using the latest version of wordpress. Is this the problem? If not, let me know.

    The events showing up multiple times in the event list will be fixed soon.

    using WPv 2.5
    (afraid to upgrade – lost the entire site going from 2.3 to 2.5!)

    just went to EC 6.0.7 and then a minute later to 6.0.8 – still have HTML and I still can’t go back & forth from one month to the next – do you think it could be related?

    shoot me an email through my site contact form. I apologize but I had completely let your issue slip my mind. I do apologize, but contact me through the site so I can get the details.


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Events Calendar] HTML showing up in popup!’ is closed to new replies.