Support » Plugin: Event Organiser » [Plugin: Event Organiser] Venues not showing

  • Resolved stephbealee

    (@stephbealee)


    It says I add venues successfully but doesn’t show them in the venue list, nor can I pull them when making an event. It does however, show in the right hand side that there are 3 venues. The number goes up whenever I create one but it never shows them in the list and doesn’t allow me to access them.

    Here’s a screenshot

    Not sure if this matters since everything else works fine, but I’m on WooThemes, Spector theme.

    Thanks for any help you can offer, it’s been a really easy to use plugin so far! 🙂

    http://wordpress.org/extend/plugins/event-organiser/

Viewing 15 replies - 1 through 15 (of 24 total)
  • I can’t seem to replicate this bug. Have you tried temporarily deactivating all other plug-ins and the theme (though it seems unlikely that this is the cause). Also, try re-saving the number of venues to ‘show on screen’ in the screen settings. You’re using 1.3, did you upgrade from a previous version or is this a fresh install?

    Hey Stephen,

    Thanks for the quick reply. It’s a fresh install.

    I did the plug-in and the theme deactivation and am still getting the same results. I also tried changing the number of venues it shows and still doesn’t show them.

    Any other thoughts on how to approach it?

    Hi Steph
    Sorry that hasn’t worked for you. You could try removing and re-installing the plug-in. (Very) occasionally files can be corrupted when downloaded and installed.

    Other than that, I’m stumped. The plug-in works without any plug-ins, and the TwentyEleven theme – so if its still not working for you under those conditions, I can’t think of anything else other than a corrupted isntall. :S

    Thanks for the help, Stephen! Think I’m going to try a reinstall. Fingers crossed… 🙂

    Real quick, as much as I tried, I couldn’t find an answer to this. Is there a way to export the event info I’ve already inputted into Event Organiser? I’ve tried looking around and I think I read somewhere you can, I just can’t figure it out.

    The Plug-in settings page has an import/export tab that allows to import/export events by uploading/downloading an ICAL file.

    Darg! *head hung in shame* So easy to find, yet I missed it.

    Tried a reinstall and sorry to say, no fix. 🙁 Thanks for all your help!

    Mmmm.. seems to be an issue get_terms. If this is a private website try:

    var_dump(get_terms('event-venue',array('hide_empty'=>false)));

    in your index.php (just above the loop). If its not you can either create a private page witha custom template and use it there. (Or just remove the line quickly so visitors don’t see it). Post here what it displays.

    Thanks Stephen. I’m going to take a look at if I can make it work after I get the other portions of the site up and running. Will keep you updated!

    I had uninstalled it after exporting out the data. When I tried to reupload the .ics file, it failed. The file opens fine in Google Calendar so it seems there is something on my site that is just not cooperating with the plug-in. 🙁

    Well, I’m having the exact same issue D:

    There have been 4 reports of this bug. I’m yet to determine what the cause is. Could you try adding the following to line 134 of event-organiser-venues.php:
    var_dump(get_terms('event-venue',array('hide_empty'=>false)));

    and let me know what is displayed (on the venues admin screen).

    Also, could you try disabling all other plug-ins and using the TwentyEleven theme – if there is a conflict this will highlight it.

    Don’t know if i have done it right on the code, but this showed up at the top of the venue admin screen after adding that on line 134:

    array(0) { }

    Thanks @lucaslucena – just to check: you’ve created terms successfully, (and the number of venues seems correct), but they are not displaying at all? Have you tried disabling all other plug-ins / themes? Most people don’t seem to be experiencing this issue so I think it could be a conflict.

    Yes, I did everything right. I’m gonna try disabling everything later so I can give you a feedback. Thanks for the attention!

    Thanks lucaslucena – I’m hoping to get to the bottom of this once and for all :D. Would you be able to visit this page in your admin screen:
    wp-admin/edit-tags.php?taxonomy=event-venue&post_type=event

    Do the venues appear there? Also, what set up do you have? Is it WP 3.3.1, EO 1.3.2? Are you running multisite?

    Still nothing shows up. I am using WordPress 3.3.1 not multisite.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: Event Organiser] Venues not showing’ is closed to new replies.