Event Organiser
Permalink Setting Breaks Event Permalink? (2 posts)

  1. watermelonkid
    Posted 3 years ago #


    Great plugin, but I'm having trouble getting the plugin to cooperate with my permalink setting. My site uses the most common custom permalink setting:


    So, when I try to visit an event on my site (Test Event 1), the default setting in the plugin is:


    which renders:


    However, upon entering this into a browser, it redirects to:


    What am I doing wrong with the permalink settings?


  2. Stephen Harris
    Plugin Author

    Posted 3 years ago #

    Hi watermelonkid,
    I've just tested that structure on my site and it doesn't redirect.

    The problem your experiencing, I think, is due to 'canonical redirection' which exists to help improve your site's SEO (debatable :) ). Since several urls can point to the same content (including 'incorrect' ones) - WordPress redirects the user to the correct or 'canonical' url. This on its own shouldn't cause the issue.

    EO doesn't interfere with that process - but other plug-ins may do. And since it seems to work on my test install, it suggests this may be the case.

    I would first visit your Permalink > Settings page and click 'save' a few times - just to ensure the rewrite rules are properly flushed.

    If that doesn't solve it, try uninstall all plug-ins/theme and flushing the permalinks again. If a plug-in/theme is causing the issue that will highlight it.

    Typically though, there shouldn't be a problem - WordPress handles the permalinks for your posts and the post type event.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Event Organiser
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic