WordPress.org

Support

Support » Plugins and Hacks » Event Organiser » [Resolved] [Plugin: Event Organiser] 1.5.2 Schedule and Agenda Errors

[Resolved] [Plugin: Event Organiser] 1.5.2 Schedule and Agenda Errors

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hi Darren.
    I’m not having any trouble updating events – nor with the agenda widget. Have you tried disabling all other plug-ins and switching to TwentyEleven – just to see if there isn’t a conflict somewhere in your set up?

    Do you get any error messages when saving an event?

    For the agenda widget, what dtate/ime formats do you have saved?

    Thanks Stephen,

    As mentioned in my other thread I will test disabling other plugins. I haven’t been getting error messages. After I click update the page would refresh with the old schedule.

    I had downgraded to 1.5.1 but the problem still happened which seems to point to external factors.

    Shall keep you posted.

    Hi Stephen,

    I upgraded to 1.5.3 so I would have the latest version and disabled all the plugins and the schedule won’t save. Saving a once off event works but when trying to save a recurring event it reverts back to it’s previous setting. If it is a new event it reverts to the current data and time.

    Could you put WordPress into debug mode and report back with any error messages you get when saving a recurring event?

    If you don’t get any then there are other things that can try to diagnose the problem…

    Thanks for your quick replies Stephen. I enabled debug and got this.

    Notice: add_custom_background is deprecated since version 3.4! Use add_theme_support( 'custom-background', $args ) instead. in /home/thecross/public_html/wp-includes/functions.php on line 2628
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/thecross/public_html/wp-includes/functions.php:2628) in /home/thecross/public_html/wp-includes/pluggable.php on line 881

    I found where it had been used in my theme and commented it out seeing as I’m not using it anyway.

    I tried adjusting the event schedule and didn’t get any errors but the schedule reverted to the previous settings again.

    I just spotted this on the sidebar above the agenda widget.

    Notice: Undefined index: mode in /wp-content/plugins/event-organiser/classes/class-eo-agenda-widget.php on line 71

    Seems like the ‘mode’ setting of the agenda widget is missing from your database. All I can suggest is to try re-saving the agenda widget settings.

    As the events not saving – it doesn’t appear there is an error – so it could be the save routine ending early. So it’ll be good to know at what point it fails. In includes/event.php just above line 81 add the following:

    echo '<pre>';
    print_r($event_data);
    wp_die();
    //Generate occurrences

    This will print the data being sent to the plug-in and kill the processing early. You should a blank screen with data printed. If you do, check if it is what you expect (it’ll contain data like the start date, end date, schedule, included/excluded dates etc). If you don’t, then its failing before that point.

    Re-saving the agenda widget settings did the trick!!! Thanks.

    I added the code before line 81 and no change. After clicking update the screen refreshed with the old dates. Not the result you were wanting to see I imagine.

    I added the code to line 31 just after $post_id = (int) $post_id; and this is the result.

    Array
    (
        [start] => DateTime Object
            (
                [date] => 2012-09-15 09:00:00
                [timezone_type] => 3
                [timezone] => America/Denver
            )
    
        [end] => DateTime Object
            (
                [date] => 2012-09-15 10:30:00
                [timezone_type] => 3
                [timezone] => America/Denver
            )
    
        [all_day] => 0
        [schedule] => monthly
        [frequency] => 1
        [schedule_last] => DateTime Object
            (
                [date] => 2032-09-15 09:00:00
                [timezone_type] => 3
                [timezone] => America/Denver
            )
    
        [schedule_meta] =>
        [include] => Array
            (
            )
    
        [exclude] => Array
            (
            )
    
    )

    Can you confirm that this only effects events recurring every month?

    I’ve noticed a couple of potential bugs…

    Here is the run-down of my tests.

    Once works
    Daily works
    Weekly works
    Monthly doesn’t
    Yearly works
    Custom no options appear. Is this correct?

    I hope that helps narrow things down.

    Yup, I’ll be releasing a fix later tonight – I’m really surprised this wasn’t noticed by more people.

    From what my tests, and checking the source I think the updating the monthly schedule does work if you also change other details (date/time etc). EO runs a check when saving an event to see if the schedule data (start date/time, frequency, schedule period etc) is any different from the currently saved one (this means it doesn’t unnecessarily regenerate occurrences). In this case it incorrectly thinks it is the same schedule data – so doesn’t update.

    Custom has no options. Basically custom is a single event with extra dates included (if you save a single event with a date added it switches it to ‘custom’). The idea is that a ‘single’ event with added dates is no longer a single event – so shouldn’t be called ‘single’. On the other hand a weekly recurring event with dates added/excluded is still a weekly recurring event.

    Think of ‘custom’ as an event with arbitrary many occurrences and no general pattern 🙂

    Yes, I’m having the same issue… can’t update event schedule with “monthly” recurrence… Doesn’t matter if I change the info or not… still doesn’t save.

    I can’t even create a new event with a monthly recurrence.

    This should have been fixed in 1.5.4. It has for me, but if either of you could confirm that, that’d be great :).

    Yep, working now!

    Thanks for the great plugin, by the way.

    Also, any plan to add in more complex recurrence preferences? I’d like an event to recur on the 2nd and 4th Tuesday… so far the only way to do this is to create two separate identical events (each set to recur once per month on different weeks).

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] [Plugin: Event Organiser] 1.5.2 Schedule and Agenda Errors’ is closed to new replies.
Skip to toolbar