Support » Plugin: Event-O-Matic » [Plugin: Event-O-Matic] Question about tags being applied to every line

  • Resolved Val88

    (@val88)


    Matthew – Your plug-in is excellent. Very useful, but I’m having problems with formatting. Every string of html coming out of [eom-listings] has “strong” | “/strong” tags applied. This makes all text and headers on the page bold.

    Digging into the code, I determined that the function in your plugin eomListings() formats the html properly, no spurious “strong” tags are inserted. The problem seems to be that the “strong” tags are being applied by the WP core function apply_filters() during the page.php the_content() call. The filter function is bolding everything. Is there a filter attribute that needs to initialized or set in the eom plugin, so that the detailed event listings display per the formatting set in the eomListings() function, rather than having spurious tags inserted by WP filtering?

    Any help/advice would be appreciated. Been chasing this all day.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Matthew

    (@mjgarvi)

    I’ll look into this tonight. Thanks for the heads up.

    We’re you able to recreate the problem? I should have mentioned I observed the problem only in the detailed, single event listing, not the multiple events listings that are created by eomListings(). I found a workaround by echoing the string in the eomListings() function itself and returning no parameter back to the WP core functions. It’s not an ideal solution, but it works well enough for now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Event-O-Matic] Question about tags being applied to every line’ is closed to new replies.