[Plugin: eShop] Blank screen (10 posts)

  1. blagodat
    Posted 7 years ago #

    I have version 2.6.3 of plugin when I upgraded to 2.7 I got blanc screen like some user described before. Tried to disable and reenable plugins and it did not helped. When switched back to the old version it started working fine again. Any advise?

  2. elfin

    Posted 7 years ago #

    Not really - but I haven't tested an upgrade from 2.6.3 to 2.7

    Could you let me know which version oh php/mysql/wordpress you have and I'll have a look to see what I can do. But if I'm unable to replicate the problem I might not be able to do much.

  3. elfin

    Posted 7 years ago #

    This seems to be affecting quite a few people.

    The problem is I can't duplicate the error making it virtually impossible for me to track down what is going on.

    If anyone is prepared to send me login details - including FTP - to an affected site I will do my best to find the fault. Hopefully I will then be able to rectify it.

    I can be contacted via elfin at elfden dot co dot uk

  4. elfin

    Posted 7 years ago #

    If you get a blank screen after trying to activate eShop the most likely cause is a permissions problem on your wp-content directory.

    You may need to play with what you should set it at, but setting it to 777 will enable the plugin to be activated correctly.

  5. elfin

    Posted 7 years ago #

    I've just released version 2.7.3 which should fix the blank screen issue - if you still have problems please don't hesitate to let me know.

  6. blagodat
    Posted 7 years ago #

    Thank you for the fix! Now it works!

  7. mikehcg
    Posted 7 years ago #

    I just installed WP 2.7 this morning (11.11.08) the upgrade worked without a problem. But, I called the site up and got a blank screen too.

    My server has PHP Version 5.1.6 and MySQL 5.0.45 running.

    I did have similar problems with an other software package which had code from PHP V5.1.3 which did not work on my server. I don't know if that has anything to do with this problem.


  8. elfin

    Posted 7 years ago #

    It looks like you'll have to manually create some directories.

    Try creating these 2 directories manually, and then activating eshop and see if it helps.


    You will also need to copy some files into those directories from the plugin:
    eshop/downloads & eshop/files.

    Hopefully that will solve the issue.

  9. elfin

    Posted 7 years ago #

    oops wrong answer - you are upgrading.

    delete the plugin, or deactivate if you can.

    If the latest version doesn't install then I'm not sure what is causing this issue.

  10. mikehcg
    Posted 7 years ago #

    Looks as though one of my plugins is the culprit. I'll just delete them and try them one after another until I find it. Thanks for the tip.

Topic Closed

This topic has been closed to new replies.

About this Topic