• Hi:

    When I go to my Entires page for the forms I get the below messages… Aside from that I also get an error on my main New Hire Form when submitted it displays to the user “An error occurred, please try again later”. Any sugguestions? Errors happened after updates.

    Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 37

    Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 37

    Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 38

    Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 38

    Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 39

    Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 39

    Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 40

    Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 40

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author EDGARROJAS

    (@edgarrojas)

    Hello!

    Those are actually only notices not errors. I will check why they show up but i recommend you to disable notices in production serves since displaying them could be a security issue. You can disable them like this: https://aristath.github.io/blog/wp-hide-php-errors

    Regarding the error message, could you send me a link to the form that is throwing the error?

    Edgar:

    Our WordPress site is internal so I can’t provide a link. What I can tell you is my other form seems to be working except my new hire form after the updates. After submit it just says “An error occurred, please try again later”. No emails are sent out but I can see the information in the entries table. I’m going to try to remove all the emails and re-add them to ensure one isn’t causing an issue. Anymore suggestions?

    Plugin Author EDGARROJAS

    (@edgarrojas)

    Ah i see.

    Could you check in the ‘entries’ screen if the entry was recorded? Also could you check your php log? Sometimes the php log record the reason why the form was not recorded.

    Hope this helps but if it doesn’t please let me know.

    Within the Entries table, all entries are being recorded even though there’s an error after hitting the submit button. No emails are being sent. From my debug log I pretty much saw the same errors as before when I turned off debugging. Here is what the log pulled from today. I even tried recreating a new form but that one has the same effect, yet I have another form that still functions correctly. I appreciate your time with trying to help me out.

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 37

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 37

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 38

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 38

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 39

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 39

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant id – assumed ‘id’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 40

    [14-Sep-2017 13:27:41 UTC] PHP Notice: Use of undefined constant section – assumed ‘section’ in /var/www/html/wp-content/plugins/smart-forms/additional_fields/smart-forms-additional-fields-list.php on line 40

    Also if this helps, the form completes successfully when testing from the preview button. It’s when I add it to a webpage it starts to fail.

    Plugin Author EDGARROJAS

    (@edgarrojas)

    Got it, those are actually notices not error (they will be fixed in the next release though), isn’t there any error in the log?.

    Maybe your site is configured to show the notices in the page, if so those notices would be added to the submission response that your server send and would make it invalid. This could explain why everything is saved but you are still getting the ‘An error occurred’ message. so could you try to disable them? You can disable them like this: https://aristath.github.io/blog/wp-hide-php-errors (which btw is recommended in a production site).

    Edgar:

    Okay, I tried both methods. The first method I tried yesterday but forgot to mention. After reading the article I replaced the one line of code define('WP_DEBUG', false); with the 4 lines in the wp-config.php file. As of now the form is still behaving in the same manner.

    Referring to the 4 lines that were inserted as a replacement

    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_DISPLAY', false);
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin Errors’ is closed to new replies.