Support » Fixing WordPress » Plugin Error / Pot, server issues?

  • Been having issues the whole day accessing plugins. It looked like it was sorted… how ever, now i recive this:

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Out of curiosity, are you noticing any other admin area timeouts, perhaps with server error 502 being reported? If so, when did it first start?

    To answer your question more directly, the wordpress.org repo is very occasionally inaccessible. When it happens to me I usually wait a few hours for the WordPress plugin server to come back up.

    Following issues found while doing a health check:

    PHP Version: 5.6.37 – For best performance we recommend using PHP 7.2 or higher.

    Communication with WordPress.org: Unable to reach WordPress.org at 198.143.164.252: cURL error 28: Connection timed out after 10004 milliseconds

    HTTPS status: You are accessing this website using HTTPS, but your WordPress Address is not set up to use HTTPS by default.

    Background updates: A plugin has prevented updates by disabling wp_version_check().

    Loopback request: The loopback request to your site failed, this may prevent WP_Cron from working, along with theme and plugin editors.
    Error encountered: (0) cURL error 28: Operation timed out after 10003 milliseconds with 0 bytes received

    If you use cPanel (most servers that WordPress is installed on do use cPanel), login to cPanel and edit the PHP settings.

    There is a search feature in cPanel. Type in PHP then click the button that lets you configure/tweak PHP settings. Set PHP to version 7.2, click set as default then click save.

    Next you will want to set the PHP variables. The same PHP screen should have a link that takes you to the variables editor. Increase values e.g. memory (to 192), upload size (to 64) and post size (to 64 or to 128) and timeouts (to 300). The exact titles are different. You might need to create a php.ini file under public_html with the content default_socket_timeout = 300, which sets the cURL timeout time.

    Additionally you will want to change the site address under WP Dashboard > Settings to change http:// to https://.

    Looks like one of your plugins is at fault too. Did you buy a nulled plugin? Or have you installed a plugin downloaded from a dodgy website? Disable plugins one-by-one and retry to run updates.

    Let me do this quick! And let you know

    Ps. No strange downloads. This just suddenly happened this morning. Yesterday everything was working fine. Our terrible host, however, apparently updated their servers this morning… maybe that caused some drama here?

    I did a health check now, and now it’s only these left:

    Unable to reach WordPress.org at 198.143.164.252: cURL error 28: Connection timed out after 10001 milliseconds

    5.6.37 – For best performance we recommend using PHP 7.2 or higher.

    And this: Couldn’t retrieve a list of the checksums for WordPress 4.9.8. This could mean that connections are failing to WordPress.org

    Looks like you didn’t click ‘Set as default’ when you switched PHP to 7.2 or 7.1 or even 7.0.

    Looks like you host with Hostgator. That IP address is for an HG server. WordPress.org is at a different set of IP addresses.

    Edit: The IP address is used by wordpress.org.

    We cant access cPanel right now – it doesnt work since this morning.

    Our host is Afrihost.co.za.

    So i guess i need to email them and tell them to update everything?

    Ps. Im super grateful for all your help.

    I did one more health check – and the only issue now is the PHP version..

    Oh, I was wrong. That IP address is a wordpress.org address. The tool I used to detect it showed it as belonging to Hostgator. Sorry about the confusion.

    I would adjust the cURL timeout and send a ping to that IP address from your webserver. Your server’s IP address could be blocked. When I ping from the UK I see no errors.

    Speaking with your host should help too.

    If your cPanel account (or other server admin panel) won’t let you change the PHP version you will need to ask your host to make the change for you.

    There is one more issue.

    The site looks different on the mobile version:

    -Menu button doesn’t work
    -Fonts are wrong

    I had issues this morning, couldnt access plugins. So reactivated them one by one, but since that mobile version looks strange. Not sure why. Maybe there is a plugin i missed?

    Have you run a malware scan with WordFence?

    It was WordFence that caused this, when i did the health check:

    Background updates: A plugin has prevented updates by disabling wp_version_check().

    Reinstalled it, now it doest cause that issue.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Plugin Error / Pot, server issues?’ is closed to new replies.