Support » Plugin: Ozpital WPWeTransfer » Plugin error in CF7

  • iancumarian

    (@iancumarian)


    Hello!

    First of all, thanks for the plugin, it’s great, really good work.

    I need your help, the plugin works perfectly, but when i insert it in CF7 it doesn’t load correctly, for example:
    – instead of “add your file” button, there’s a “${label}”
    – the $ button opens the browser window, but doesn’t “attach” the file
    – the transfer button doesn’t work.

    I mention that i put the “add filter” function to the functions.php so that the CF7 could load the ozpital shortcode.

    add_filter( ‘wpcf7_form_elements’, ‘mycustom_wpcf7_form_elements’ );
    function mycustom_wpcf7_form_elements( $form ) {
    $form = do_shortcode( $form );
    return $form;
    }

    I made an example page with the contact form and below the plugin alone which works perfectly.

    Thank you.
    Regards,
    Iancu Marian.

    • This topic was modified 11 months ago by iancumarian.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Got the same problem unfortunately.. Now I know how to change the faulty text by jQuery but that does not bring the functionality of the plugin back 😛

    Would be very great to have this fixed.

    Hi!
    Thanks for sharing.
    Can you tell me, please, what theme and/or page builder do you use?

    I use the APEX theme from Sonaar.io. Page builder = WPBakery

    EDIT: Seems like OP has removed his CF7 on the page, I just set one up on my page so you can see the error:

    http://oyosounds.com/mixing-mastering/

    You can now see it. I’ve added your code to my functions.php to activate custom shortcodes inside CF7, namely:

    // Shortcode inside CF7
    add_filter(‘wpcf7_form_elements’, function($form) {
    return do_shortcode($form);
    });

    • This reply was modified 10 months, 3 weeks ago by skillful058.
    • This reply was modified 10 months, 3 weeks ago by skillful058. Reason: needed to provide page for demonstration

    Coded some workarounds for myself, my case is solved. Don’t know about OP though!

    Can you please tell me what you did?

    Same problem here. It would be great for me too to know how you fixed it. Thank you !

    Same issue as OP, anyone know the solution?

    Plugin Author ozpital

    (@ozpital)

    Ok, I’ve investigated. Thanks for your patience (I don’t check here often, @greyhood found me on Twitter and DM’d me).

    This isn’t going to work easily. You’re essentially nesting a form inside a form and WordPress cleans it up by removing the nested <form> element. I expect the browser will have issues as well even if it got that far as to display the ozpital-wpwetransfer form inside the CF7 form.

    In the short term, don’t include the [ozpital-wpwetransfer] shortcode in your CF7 form. You’ll have to add the [ozpital-wpwetransfer] shortcode along side your CF7 shortcode in your post/page content instead. eg: [ozpital-wpwetransfer] [contact-form-7 id="02" title="A contact form"] . That will fix the problem.

    Sorry for the bad news but there is clear demand for a CF7 wetransfer plugin so I’ll work on a solution as soon as I can so you can all just drop in a shortcode into CF7 and it magically just works. Bare with me. It will land sooner rather than later, maybe a couple of weeks from now.

    • This reply was modified 10 months, 1 week ago by ozpital.
    • This reply was modified 10 months, 1 week ago by ozpital.

    Oh sorry guys, totally forgot to reply. Okay, so basically the shortcode inside CF7 is not working (yet) and that sucks. But think in solutions, not in problems :).

    I’ve added the ozpital shortcode just above my CF7 shortcode and in the CF7 form itself I’ve added the wetransfer_url box with the required option selected. I chose for hiding this “wetransfer_url” box by using CSS. This way it seems like the wetransfer upload thing is part of the form while it is actually not. Downside is you can only place the WeTransfer upload box above or underneath your CF7 form, not inside. Because the required option for “wetransfer_url” is selected, the form will not send in case files are not added (since the wetransfer url will not be generated, therefore the wetransfer_url box is not filled in).

    @ozpital @skillful058 ok thanks guys

    Yeah I had it working outside the contact form which is still great, but of course it would have been nice to have it near the end of a form.

    Not that it matters but just as an example, you have a form when people specifically upload items, the widget is perfectly fine to be above the form inputs.

    However, with a form when uploads are optional it’s nice to have the uploaded near the end of the form, that’s all. etc. etc.

    Appreciate the help

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Plugin error in CF7’ is closed to new replies.