Support » Plugin: Яндекс.Касса 2.0 для Woocommerce » Plugin error after update E_COMPILE_ERROR was caused in line 191

  • vladimir.bulgaru

    (@vladimirbulgaru)


    An error of type E_COMPILE_ERROR was caused in line 191 of the file /var/www/***/htdocs/wp-content/plugins/yandex-money-checkout/includes/YandexMoneyCheckoutPayment.php. Error message: require_once(): Failed opening required '/var/www/***/htdocs/wp-content/plugins/yandex-money-checkout/gateway/YandexMoneyWidgetGateway.php' (include_path='.:/usr/share/php')

Viewing 10 replies - 1 through 10 (of 10 total)
  • vladimir.bulgaru

    (@vladimirbulgaru)

    Update on debugging:
    YandexMoneyWidgetGateway.php does not exist. Wow, curious how the testing was done 😀

    The good news is – you can fix the issue by commenting the line 191 in the file /wp-content/plugins/yandex-money-checkout/includes/YandexMoneyCheckoutPayment.php

    vladimir.bulgaru

    (@vladimirbulgaru)

    Update #2:
    No love, since the WPML plugin crashes after commenting that line. It appears that since the Gateway is registered, it expects the class to exist. Looking for downgrade.

    vladimir.bulgaru

    (@vladimirbulgaru)

    Update #3:
    To prevent WPML error (and who knows what other errors), comment out the line 145 as well:
    //$methods[] = 'YandexMoneyWidgetGateway';

    warmy

    (@warmy)

    “На сайте возникли временные проблемы технического характера.”

    После последнего апдейта модуля.

    ostulov

    (@ostulov)

    Добрый день!

    Благодарю за обращение, ошибка в плагине была исправлена 5 октября. Вы можете обновить плагин до последней версии.

    warmy

    (@warmy)

    Именно с 5 октября и крашится сайт при обновлении плагина. Версия 1.3.0

    vladimir.bulgaru

    (@vladimirbulgaru)

    I really don’t get why it was so difficult to change the version number. It was clear that version 1.3.0 was flawed and the developers could’ve issued a version like at least 1.3.0.1. In any case i confirm – deleting and installing back the plugin solves the issue (they’ve added the missing file).

    warmy

    (@warmy)

    Переустановил плагин сейчас, проблема падения сайта ушла, благодарю.
    Версия плагина была 1.3.0 а стала 1.3.0 – не очень информативно.

    ostulov

    (@ostulov)

    5 октября был выпущен быстрый фикс, который исправляет проблему с падением сайта. Версия плагина не обновилась и осталась 1.3.0.

    Мы уже приступили к решению проблемы с невозможностью редактирования товара и изменением цвета фона. Сегодня планируем выпустить фикс, у него изменим номер версии на 1.3.1.

    ostulov

    (@ostulov)

    Выложили обновление плагина для решения проблемы с редактированием товаров и изменением фона.
    Новая версия плагина – 1.3.1, Вы можете сделать автообновление со страницы со списком плагинов WordPress.
    Приношу извинения за доставленные неудобства!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Plugin error after update E_COMPILE_ERROR was caused in line 191’ is closed to new replies.