Support » Plugin: Include Klaviyo for Elementor pro » Plugin Error

  • Resolved dwellness

    (@dwellness)


    Hi, thank you for making this plug in. It was working well but today I received this message from wordpress saying that this plugin was causing issues with my site. Below are the error details they sent me.

    Error Details
    =============
    An error of type E_ERROR was caused in line 296 of the file /home/customer/www/dose.land/public_html/wp-content/plugins/include-klaviyo-for-elementor-pro/include-elementor-klaviyo.php. Error message: Uncaught Error: Call to a member function get_modules() on null in /home/customer/www/dose.land/public_html/wp-content/plugins/include-klaviyo-for-elementor-pro/include-elementor-klaviyo.php:296
    Stack trace:
    #0 /home/customer/www/dose.land/public_html/wp-includes/class-wp-hook.php(303): Tho_Elementor_Extension->init_widgets(Object(Elementor\Widgets_Manager))
    #1 /home/customer/www/dose.land/public_html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
    #2 /home/customer/www/dose.land/public_html/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
    #3 /home/customer/www/dose.land/public_html/wp-content/plugins/elementor/includes/managers/widgets.php(109): do_action(‘elementor/widge…’, Object(Elementor\Widgets_Manager))
    #4 /home/customer/www/dose.land/public_html/wp-content/plugins/elementor/includes/managers/widgets.php(302): Elementor\Widgets_Manager->init_widgets()
    #5 /home/customer/www/dose.land/public_html/wp-content/plugins/elementor/includes/elements/column.php(1037): Elementor\Wi

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author thongnguyenminh

    (@thongnguyenminh)

    Hi @dwellness thanks for your question. Can you please tell me what version of Elementor, Elementor pro and WP you are current use?

    Thread Starter dwellness

    (@dwellness)

    Thanks for the quick reply

    WordPress version 5.8.2
    Current theme: Astra (version 3.7.6)
    PHP version 7.4.27
    Elementor Version 3.5.3
    Elementor Pro Version 1.6.7

    Thread Starter dwellness

    (@dwellness)

    Sorry my mistake I am actually using Elementor Pro 3.5.2

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    @thongnguyenminh I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    https://wordpress.org/support/guidelines/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us escalating this to the plugins team.

    It’s never necessary to do that. Here’s why.

    There are many ways to get information you need and accessing the user’s site is not one of them. That’s going too far.

    You get the idea.

    Volunteer support is not easy. But these forums need to a safe place for all users, experienced or new. Accessing their system that way is a short cut that will get you into real trouble in these forums.

    Plugin Author thongnguyenminh

    (@thongnguyenminh)

    Hi @dwellness i have install and test the plugin with:
    A fresh new WP 5.8.2
    PHP version 7.4
    Theme Twenty Twenty-One
    Elementor Version 3.5.3
    Elementor Pro Version 3.5.2

    There is no error or issue occurred or logged. But i notice that, when install Elementor and Elementor Pro, there will be an database update process. I think may be this cause the issue.

    Can you please temporary deactivate or uninstall my plugin. Then make sure the database update process is completed (If you not sure about the database update process, then please re install both Elementor and Elementor pro) before reinstall/activate my plugin.

    Hope this help, please fell free to ask me if the issue not solved, we will try another ways.

    Plugin Author thongnguyenminh

    (@thongnguyenminh)

    Hi @sterndata thanks for your notification. This is my careless – yes i don’t think about all the risk when asking for the login info. I just want to solve this as soon as possible.

    I promise will not repeat this any more.

    And thanks you for the details information about further troubleshoot steps, this will help me in the future.

    Have a great day!

    Plugin Author thongnguyenminh

    (@thongnguyenminh)

    Hi @dwellness it’s a while, and i don’t hear from you. Do your issue solved?

    Plugin Author thongnguyenminh

    (@thongnguyenminh)

    Hi @dwellness it’s more than three weeks from your last message. So i will mark this topic as resolved. If you need any support. please fell free to asking me.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin Error’ is closed to new replies.