• Resolved dheerajmanral

    (@dheerajmanral)


    Upgrade version 2.1.0 is giving following error-

    Warning: include_once(/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php): failed to open stream: No such file or directory

    Warning: include_once(): Failed opening ‘/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php’ for inclusion (include_path=’.:/usr/local/php71/pear’)

    How to fix this?

    • This topic was modified 4 months, 2 weeks ago by dheerajmanral.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @dheerajmanral ,

    I’m sorry to hear about this issue with our plugin.

    I have tested it on my lab site and I wasn’t able to replicate those warnings.

    Can you try to reinstall plugin? If that won’t help can you tell me what PHP version you have on your server?

    kind regards,
    Kasia

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @dheerajmanral,

    I’ve released an update with the fix for the issue. Sorry for that.

    Best regards,
    Anton

    Thank you for the update

    I’m getting a similar error which shows in the header of my blog AND my WP dashboard. The Hummingbird plugin isn’t showing an update available. The errors are:

    Warning: include_once(/home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php): failed to open stream: No such file or directory in /home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/advanced-cache.php on line 24

    Warning: include_once(): Failed opening ‘/home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php’ for inclusion (include_path=’.:/opt/alt/php72/usr/share/pear’) in /home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/advanced-cache.php on line 24

    Warning: include_once(/home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php): failed to open stream: No such file or directory in /home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/advanced-cache.php on line 25

    Warning: include_once(): Failed opening ‘/home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php’ for inclusion (include_path=’.:/opt/alt/php72/usr/share/pear’) in /home/rc72flbipaey/public_html/ginkgosociety.org/wp-content/advanced-cache.php on line 25

    Plugin Author Anton Vanyukov

    (@vanyukov)

    Hi @ysmr,

    Could you please disable/enable page caching in Hummingbird. That should resolve the issue.

    Best regards,
    Anton

    aneezr

    (@aneezr)

    Hi @vanyukov

    I am getting an error on my website, I couldn’t log in to the dashboard to disable the plugin as well as you mentioned above.

    Please, can you guide me with the process?

    Warning: include_once(/home/customer/www/***.com/public_html/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php): failed to open stream: No such file or directory in /home/customer/www/***.com/public_html/wp-content/advanced-cache.php on line 24

    Warning: include_once(): Failed opening ‘/home/customer/www/***.com/public_html/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php’ for inclusion (include_path=’.:/usr/local/php71/pear’) in /home/customer/www/***.com/public_html/wp-content/advanced-cache.php on line 24

    Warning: include_once(/home/customer/www/***.com/public_html/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php): failed to open stream: No such file or directory in /home/customer/www/***.com/public_html/wp-content/advanced-cache.php on line 25

    Warning: include_once(): Failed opening ‘/home/customer/www/***.com/public_html/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php’ for inclusion (include_path=’.:/usr/local/php71/pear’) in /home/customer/www/***.com/public_html/wp-content/advanced-cache.php on line 25

    Warning: Cannot modify header information – headers already sent by (output started at /home/customer/www/***.com/public_html/wp-content/advanced-cache.php:24) in /home/customer/www/***.com/public_html/wp-content/plugins/hummingbird-performance/core/modules/class-page-cache.php on line 1273

    Hi:
    I have the same error, both in the backend and frontend:
    Warning: include_once(/home/…/class-abstract-module.php): failed to open stream: No such file or directory in /home/…/advanced-cache.php on line 24

    Warning: include_once(): Failed opening ‘…/class-abstract-module.php’ for inclusion (include_path=’.:/usr/local/php71/pear’) in /home/…/advanced-cache.php on line 24

    Warning: include_once(/home/…/class-module-page-cache.php): failed to open stream: No such file or directory in /home/…/advanced-cache.php on line 25

    Warning: include_once(): Failed opening ‘/home/…/class-module-page-cache.php’ for inclusion (include_path=’.:/usr/local/php71/pear’) in /home/…/advanced-cache.php on line 25

    I deactivated and activate the plugin and nothing happens.

    Help please.

    Thanks,

    • This reply was modified 1 month, 4 weeks ago by pablolarah.
    • This reply was modified 1 month, 4 weeks ago by pablolarah.

    Hi:

    I solved the problem in my website.
    I just resetted the plugin.
    Go to: Settings/Data & Settings/Reset Settings

    Also, if you want to delete it, I found an useful article here:
    https://mainwp.com/how-to-safely-remove-the-hummingbird-plugin-from-your-child-site/

    • This reply was modified 1 month, 4 weeks ago by pablolarah.
    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @aneezr ,

    Sorry to hear about this issue.

    You can try disabling plugin using FTP if those errors are preventing you from logging into Dashboard.
    https://support.bestwebsoft.com/hc/en-us/articles/204301449-Deactivate-disable-Wordpress-plugin-via-FTP

    kind regards,
    Kasia

    fixed

    • This reply was modified 1 month, 1 week ago by ezradallas.
    Plugin Author Anton Vanyukov

    (@vanyukov)

    @ezradallas, please disable/enable page caching in Hummingbird
    If you are not able to access wp-admin, remove the line
    define( ‘WP_CACHE’, true ) from your wp-config.php file. After that disable/enable page caching and everything will start working again.

    Best regards,
    Anton/

    I’m getting a similar error which shows in the header of my blog AND my WP dashboard. The Hummingbird plugin isn’t showing an update available. The errors are:

    Warning: include_once(/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php): failed to open stream: No such file or directory in /wp-content/advanced-cache.php on line 24

    Warning: include_once(): Failed opening ‘/wp-content/plugins/hummingbird-performance/core/class-abstract-module.php’ for inclusion (include_path=’.:/opt/php73u/lib/php’) in /wp-content/advanced-cache.php on line 24

    Warning: include_once(/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php): failed to open stream: No such file or directory in /wp-content/advanced-cache.php on line 25

    Warning: include_once(): Failed opening ‘/wp-content/plugins/hummingbird-performance/core/modules/class-module-page-cache.php’ for inclusion (include_path=’.:/opt/php73u/lib/php’) in /wp-content/advanced-cache.php on line 25

    appeared after the update

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @filipjaz,

    Please follow my advice above.

    Best regards,
    Anton

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.