Enhanced Menu Editor
[resolved] Empty Menu Copies (7 posts)

  1. Pewit
    Posted 3 years ago #

    I have upgraded our site to 3.4.2 and this seems to have broken the copy menu function.

    The plugin appears to create a copy but the copy doesn't contain any menu items.


    [ Please do not bump (or ping), that's not permitted here. ]

  2. MarcusPope
    Plugin Author

    Posted 3 years ago #

    Hmm, interesting. I just upgraded to version 3.4.2 and tried it with a clean wordpress installation. The test worked for me, and I received an alert stating the copy was successful.

    I discovered an issue yesterday where categories will not copy correctly. I had only developed this for pages and posts, and didn't think categories would be any different.

    Do you get an alert confirming the copy? (or perhaps with some php code errors lists?)

    What type of posts are you using in your menu? (pages, posts, categories, custom links, tags, or format? - I'm not even sure what that last one is for actually.)

    Can you confirm that you saved the source menu before making the copy?


  3. Pewit
    Posted 3 years ago #

    Yes, I did save it and I wonder if there's a plugin issue because I managed to copy a duplicate of the site it in my development system (local install).

    Interestingly, I did find that there's another menu duplicator which worked when yours didn't - which might help you.

    I find the WP custom manu editor very slow (particularly with Ubermenu installed which adds even more options to every menu item) and would like something similar to the Page Tree View to be able to modify menu items.

    It would also be great to be have the Page Hierarchy update the menu when items are imported as well as the other way round which you provide.

  4. Pewit
    Posted 3 years ago #

    ...I should add that I also got the message that the copy was successful but there was no content in the copy.

  5. MarcusPope
    Plugin Author

    Posted 3 years ago #

    It looks like the other plugin was recently created. And although they don't offer syncing their algorithm for duplicating the menu is a slightly different approach from mine. I'll investigate the concrete differences when I tackle the categories bug.

    But, oddly, I'm not sure what's going on with your situation. Are you running Ubermenu on the site that failed to copy? I can test with that plugin enabled on my testing server. And if there is anything that you can think of that would explain the difference between your development server and the production server I'd really appreciate the info. (you can email me at any address at marcuspope.com so you don't have to broadcast sensitive details about your server to the internet ;)

    The menu editor can be very slow, especially for large sites. I do have a reverse sync on the list of features I'd like to add in the future. And I don't see any problem with extending the support to the import feature, but I haven't hooked into that part of wordpress before so I'm not sure how difficult it would be.

    Thanks for all your input and support.

  6. Pewit
    Posted 3 years ago #

    Hi Marcus

    I have found the culprit - we are running Ubermenu on the site that failed to copy.

    I tested it on my development server and it's Ubermenu that causes the problem!

    No Ubermenu and it copies correctly - activate Ubermenu and it doesn't.
    I tried with Ubermenu 2.0 and

  7. MarcusPope
    Plugin Author

    Posted 3 years ago #

    Interesting, well there is another ticket open on adding support for UberMenu so I might end up tackling this issue after all. Thanks for the follow up, I'll add this to my development backlog.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Enhanced Menu Editor
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.